Modules not always loading



  • Hi All,

    I’ve been building the config over the last 2 days and have run into an issue.

    Today I loaded the MMM-MyWastePickup and installed it as per instructions. I then added the info to my config.js and run npm run config:check as normal, no errors and then restarted pm2.

    It reboots as expected but somewhat slower and then only loads 50% of the previous modules. The rest display the “Loading…” image and the new module doesn’t load either. Here’s some images to better show my issue.

    Before:
    0_1516010280104_Before WastePickup.png

    After:
    0_1516010316623_After WastePickup.png



  • Is the console where you run npm start showing any errors?
    And can you try npm start dev and see if the browser’s console shows any errors? The modules write notifications there.

    Have you tried to remove the new module from the config again to see if the problem remains?



  • I don’t use npm start… Is this an issue? I use pm2 start which shows:

    0_1516012515948_Screen Shot 2018-01-15 at 10.31.18.png

    I just ran npm start and I had:
    0_1516013008488_Screen Shot 2018-01-15 at 10.43.18.png

    Running npm start dev oddly has everything running.
    0_1516013493160_Screen Shot 2018-01-15 at 10.51.13.png

    The only error in the console relates to the weather 0_1516013617020_Screen Shot 2018-01-15 at 10.53.04.png

    Yes I have tried to remove the new module and everything goes back to the way it was.



  • Another reboot of my pi has resulted in the new module now loading but 2 others not loading.

    0_1516014708860_Screen Shot 2018-01-15 at 11.11.41.png



  • I don’t use npm start… Is this an issue? I use pm2 start which shows:

    No problem, doesn’t matter, you got the browser console.

    I had hoped that the logs would show something that would help. There where no other errors in the browser console further up? Time to contact the creator of MMM-MyWastePickup.



  • Hi @J.E.F.F ,

    I believe this is one of your modules. I love the idea and the concept and believe I can have it working for me over in the UK.

    Any ideas why the above is happening?

    Thanks



  • Your screenshot of the pm2 output shows 2 instances of magic mirror. One called mm & the other MagicMirror.

    I think if you follow the install guide it tells you to run install script (which I believe now sets up the MagicMirror instance) & then tells you to manually set up another called mm. I think the install guide might need updated.

    Could it be 2 instances running & causing issues? If so get rid of one & restart & see if that solves it.



  • Just looked at the install notes… The manual installation step is right after the auto install script so is probably why you did it (that’s my excuse anyway!)



  • @randomnoise, yes your absolutely right about why I did it. Weirdly the first time I was running the config the MagicMirror instance wasn’t created so I just went ahead with the mm instance.

    Then things went wrong I managed to corrupt everything so did a fresh install and MagicMirror was created but I failed to realise this and went ahead and created mm again.

    Would you know how I can get rid of the mm? That way I can then test your theory.

    Thanks



  • Hi @NathanWilcox,

    If you followed the manual install, you should see the shell script (mm.sh) when you run ls -la ~. Run pm2 list to see what processes are registered in pm2. You can then pm2 stop mm && pm2 delete mm && pm2 save, and finally rm ~/mm.sh.

    mm should then be gone for good, and only MagicMirror will remain. You can confirm what remains by running pm2 list again.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.