Cant run the app



  • My first time trying to build a magicmirror, and i cant solve this problem. Can you guys help me? alt text



  • Could u send the full log file in a code box here?

    cat /home/pi/.npm/_logs/2018-01-02T17_31_20_367Z-debug.log
    


  • 0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@3.10.10
    3 info using node@v6.12.2
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.2.1~prestart: magicmirror@2.2.1
    6 silly lifecycle magicmirror@2.2.1~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.2.1~start: magicmirror@2.2.1
    8 verbose lifecycle magicmirror@2.2.1~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.2.1~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.2.1~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.2.1~start: Args: [ '-c', 'sh run-start.sh' ]
    12 silly lifecycle magicmirror@2.2.1~start: Returned: code: 1  signal: null
    13 info lifecycle magicmirror@2.2.1~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.2.1 start: `sh run-start.sh`
    14 verbose stack Exit status 1
    14 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:255:16)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at EventEmitter.emit (events.js:191:7)
    14 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at ChildProcess.emit (events.js:191:7)
    14 verbose stack     at maybeClose (internal/child_process.js:920:16)
    14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
    15 verbose pkgid magicmirror@2.2.1
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.9.59-v7+
    18 error argv "/usr/bin/node" "/usr/bin/npm" "start"
    19 error node v6.12.2
    20 error npm  v3.10.10
    21 error code ELIFECYCLE
    22 error magicmirror@2.2.1 start: `sh run-start.sh`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.2.1 start script 'sh run-start.sh'.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error     sh run-start.sh
    23 error You can get information on how to open an issue for this project with:
    23 error     npm bugs magicmirror
    23 error Or if that isn't available, you can get their info via:
    23 error     npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    
    


  • @goncalovsc Is this after having run the auto install script or manually installing? Did you run npm install in the ~/MagicMirror folder? Have you tried running npm start in the same directory?

    @cruunnerr What are the permissions of your run-start.sh? It doesn’t make sense to me that mine is rw-r—r— but works fine. I would expect it needs x permissions.



  • @ninjabreadman I’ve done all that, and the error persists



  • Try to rebuild electron or reinstall with last update. npm install -g electron or npm rebuild in magic Mirror directory



  • @saljoke I’ll try later at night, when I’ve done that I’ll give you an update. Thanks



  • Did you run the install directly from the command line (without the start of the graphical user interface)?

    You should run the setup within the GUI!



  • @cpramhofer i installed by the commands, I followed a video



  • @saljoke i tryed, and exatly the same error


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.