MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Not reading RSS



  • Im trying to put this RSS (http://www.cmjornal.pt/rss) but the module just stays on "loading"
    Any guesses?



  • @goncalovsc Does the default config work, showing NYT headlines?

    module: "newsfeed",
    position: "bottom_bar",
      config: {
        feeds: [{
          title: "New York Times",
          url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml",
        }]
      }
    

    What happens when you run the following in the terminal from your MM?

    curl http://www.cmjornal.pt/rss
    

    Does this mean you succeeded in installing MM given your earlier post?



  • Yeah, i installed an older version of raspian and it worken now, 2 months later. With the NY Times it works, but with my RSS it just stays on loading



  • @ninjabreadman said in Not reading RSS:

    curl http://www.cmjornal.pt/rss

    I understood what you meened now, i runned that command and it loaded the RSS, but in the magicMirror app just says loading



  • @goncalovsc That was just to check that the MM could reach cmjornal.pt.

    Hmm, if it works with NYT, it may have a problem parsing your RSS feed. Start your MM with npm start dev to see errors in both Terminal and the Chrome/Electron JavaScript console.

    The RSS feed contains errors, but it still loads for me:

    0_1521165345095_Screen Shot 2018-03-15 at 9.54.56 PM.png



  • This is my newsfeed.js file

    // Default module config.
    	defaults: {
    		feeds: [
    			{
    				title: "Ultimas Noticias",
    				url: "http://www.cmjornal.pt/rss",
    				encoding: "UTF-8" //ISO-8859-1
    			}
    		],
    		showSourceTitle: true,
    		showPublishDate: true,
    		showDescription: false,
    		wrapTitle: true,
    		wrapDescription: true,
    		truncDescription: true,
    		lengthDescription: 400,
    		hideLoading: false,
    		reloadInterval: 5 * 60 * 1000, // every 5 minutes
    		updateInterval: 10 * 1000,
    		animationSpeed: 2.5 * 1000,
    		maxNewsItems: 0, // 0 for unlimited
    		ignoreOldItems: false,
    		ignoreOlderThan: 24 * 60 * 60 * 1000, // 1 day
    		removeStartTags: "",
    		removeEndTags: "",
    		startTags: [],
    		endTags: [],
    		prohibitedWords: []
    	},
    
    	// Define required scripts.
    	getScripts: function() {
    		return ["moment.js"];
    	},
    

    Any idea why its stuck on loading?



  • @goncalovsc Is that your full newsfeed.js file? That is definitely not the complete file. Suggest running git checkout ~/MagicMirror/modules/newsfeed.js in Terminal.

    Best practice is to not edit your module files (e.g. newsfeed.js). Instead, override the defaults with your own settings in config/config.js.



  • Thanks for the help, it was an “http://” that was missing :p
    But Now i have the se=ame problem that you had, a lot of "?"appears in special caracthers like “ç”, “ó”, etc.
    Any solution?



  • I discovered now how to fix, just changed the encoding in both files and its working