MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-RTSPStream issues



  • I have an issue getting MMM-RTSPStream to work. I did the install and ran the configuration tool. But when I include the generated code in my config…MM will not run. I feel like a big dummy since there is a config tool that does all of the hard work.

    Here is the code that I am adding:

    {
        module: "MMM-RTSPStream",
        position: "bottom_left",
        config: {
            autoStart: true,
            rotateStreams: true,
            rotateStreamTimeout: 30,
            moduleWidth: 354,
            moduleHeight: 240,
            localPlayer: 'omxplayer',
            remotePlayer: 'ffmpeg',
            showSnapWhenPaused: false,
            remoteSnaps: false,
            stream1: {
                name: 'Front Door',
                url: 'rtsp://Administrator:!Password@192.168.0.31:88/videoMain',
                frameRate: 'undefined',
                width: undefined,
                height: undefined,
                },
            }
    }
    

    Thanks for any help in advance.

    Johnny



  • have you added a , after the last closing tag } ?



  • @barnosch

    I probably did not…let me test that and I will report back.

    Thanks…

    Johnny



  • @johnny_swindle said in MMM-RTSPStream issues:

    @barnosch

    Ok…the missing comma was part of the issue. Now MM load and I see a message that says Loading MMM-RTSPStream.

    This camera is wireless…talking to a wirless rPi 3 if that is any help resolving the issue I am seeing.



  • Re: MMM-RTSPStream issues

    OK…this is what is displaying on the terminal when I launch MMM-RTSPStream and it issues and error. How and where do I address this error?

    Whoops! There was an uncaught exception...
    TypeError: `port` or a `server` must be provided
        at new WebSocketServer (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/node-rtsp-stream-es6/node_modules/ws/lib/WebSocketServer.js:44:11)
        at VideoStream.startListener (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/node-rtsp-stream-es6/src/videoStream.js:32:24)
        at Class.startListener (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_helper.js:49:32)
        at Class.socketNotificationReceived (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_helper.js:257:22)
        at Socket. (/home/pi/MagicMirror/modules/node_modules/node_helper/index.js:113:11)
        at emitTwo (events.js:106:13)
        at Socket.emit (events.js:191:7)
        at /home/pi/MagicMirror/node_modules/socket.io/lib/socket.js:513:12
        at _combinedTickCallback (internal/process/next_tick.js:67:7)
        at process._tickCallback (internal/process/next_tick.js:98:9)
    
    

    Thanks…

    Johnny



  • @johnny_swindle said in MMM-RTSPStream issues:

    This camera is wireless…talking to a wirless rPi 3 if that is any help resolving the issue I am seeing.

    This one i do not clearly understand.
    I guess it is a normal Wlan IP cam and the Rpi3 is your MagicMirror host?
    So it is a common combination (like mine)

    Have you tried to open up the URL in VLC if it plays correctly?

    rtsp://Administrator:!Password@192.168.0.31:88/videoMain
    

    Maybe play around with it. Try different things, delete this Administrator:!Password@, leave the port blank (:88) and so on.

    My config for the stream looks like this:

    stream1: {
                    	name: 'Door',
                    	url: 'rtsp://10.30.10.28',
                    	snapshotUrl: '',
                    	snapshotRefresh: 10, // Seconds
                    	frameRate: "30",
                    	port: 9999,
    			 }
    

    But if i want to access the stream via webpage, i do need to put in credentials. The module does not need them 😉

    Have you done a “npm install” within the MMM-RTSPStream folder?



  • @barnosch

    Thanks for your reply.

    Sorry I confused the issue with my description of the camera and rPi 3…yes…it is a normal combination (probably like yours).

    The URL plays correctly in VLC. I will follow your suggestion and try around with setting similar to yours.

    Johnny



  • @barnosch

    Thanks for all the suggestions.

    I did in fact do a npm install in the MMM-RTSPStream folder.

    I played around with the config using your example, but the best I got was a blank frame (that was progress, but that was the best so far.

    Open to any and all suggestions.

    Johnny



  • just for the records. You can not see the overlay (stream) if you check your changes via VNC.
    You have to sit in front of the mirror to check if it appears.

    Maybe you should highlight the module developer , he has a huge knowledge of all the stuff.



  • @barnosch

    Thank you for suggestion. I reached out to the developer and I have been able to resolve 99% of the issues. I will post my config once I have it all working. I was aware that you may not be able to see the changes via VNC. I stop MM via putty, make the changes using Nano (via putty) and then restart.

    I then walk into the next room to check the results. I will probably have to unearth my laptop and sit in front the MM to make my life easier.

    Johnny