MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MM Shows a plain Black Screen on iOS 9.3.5 device



  • Hi all,

    So to be as specific as possible in case it helps, I’ve setup MM on an RPi recently and have this working in the house in SERVER MODE.

    This setup works successfully on Andriod/PC devices without issue.

    However the iPad 2 (iOS 9.3.5) device I had lying around and target for this build actually wont show the page content, it loads in Safari/Firefox/etc and displays a black screen which I believe is the back ground colour but no content is visible (per below).

    iPad Image [Imgur]

    To test my setup I’ve checked using an iPhone 7Plus on iOS 10.2.1 which works, thus confirming it’s not an issue with Apple devices in general & just the iPad - or more likely the iOS release?

    iPhone Image [Imgur]

    If anyone has any ideas here I’d love any assistance at this point.
    I’ve tried googling similar ios9.3.5 issues and checked the MM forum as well but can’t find any other mentions of this

    EDIT: yes the port 8080 is there, Safari just hides it when you don’t highlight the address bar
    EDIT2: iPad has been factory reset in case it helps, it’s also not jailbroken



  • @shiroe
    EDIT: if someone can confirm how to fix the above with a direct image rather than just link I’ll edit original post and remove this one.



  • @shiroe I have the same issue as you and would be grateful for a resolution. I suppose the issue is related to the old Safari version on iOS 9.3.5. I’d also accept a workaround that requires a jailbreak of the iPad 2.


  • Module Developer

    @shiroe Mobile Safari on iOS 9.3 is obviously missing some features. If a module is using a function not supported by this version of Mobile Safari a black screen might happen.

    You only can debug this using Mac.



  • @idoodler FYI default modules only it still shows the same, I have a bit more time tomorrow so I’ll try reducing one by one to see if i can find exactly which doesn’t work - though I feel it’s likely going to be all of them



  • Same problem here… iPad 2 with iOS 9.3.5 and I’m getting a black screen… I tried with Google Chrome, Dolphin Browser but no good luck.
    A work around: Install VNC Server on RPi, and a client on the iPad. Go to fullscreen mode, and voila!


  • Module Developer

    @pipe-line I think we have an iOs 9 device at work. I will debug it tomorrow night. What modules do you have installed?



  • @idoodler I started with Current Weather and Weather Forecast and then only with Current Weather, but no lucky.
    Thanks!


  • Module Developer

    @pipe-line ok. I just gathered the iPad. Its an iPad mini running iOS 9.3.3. I hope I won’t forget it until I get home:)


  • Module Developer

    Issue has been identified. I am just preparing a pull request. Hold on tight!