timing on weather is off by about 8hours



  • im in Philadelphia, PA, USA. time zone is new york city in raspi-config setting.
    the time on the left side is correct with current time. however, the weather is still showing current condition from 8 hours ago.
    in the screenshot, you can see it is Thursday morning, BUT the weather is showing conditions for 8 hours ago. hence you are also seeing Wednesday’s forecast, which is yesterday.
    please help. thanks!
    0_1463068229590_mirror sh.jpg



  • I had that same problem. The time in the top right is the time when the sun “officially” sets at your location.



  • This is probably not helpful, and I apologize in advance, but I was having a different issue with the weather module. It was displaying incorrect weather obviously based on a different location even though it had previously worked fine. I was originally going by zip code, 11201, but I changed it to NewYork, and it has worked fine ever since. Perhaps if you change the location it might also fix the time glitch? Good luck!



  • @00conman said in timing on weather is off by about 8hours:

    I had that same problem. The time in the top right is the time when the sun “officially” sets at your location.

    im not referring to the sunset time. please see my screenshot and message for clarification.

    anywho, here is my config file: http://www.dablet.com/tung_quote/js/config.js

    location is set as “q: ‘Philadelphia, US’,” is that incorrect? or i must seet to zip code?



  • @tv25666 Mine actually did not work by zip code but did work as “NewYork”. You could play around with it just to see if it fixes the problem, but like I said, my problem was a bit different. I just thought I’d chime in since a simple location change fixed my issue!

    Good luck!



  • I had a hard time with openweather as well, what I finally got to work was using the full City,State (No Space) as my location. What helped me was going to the openweather site and typing in different combinations until I found the one that was for my city which according to them there are 6 different city’s in the US with that name.

    For Philadelphia what works is Philadelphia,Pennsylvania (Note there is NO SPACE between the city and state)
    http://openweathermap.org/city/4560349



  • @pugsly said in timing on weather is off by about 8hours:

    I had a hard time with openweather as well, what I finally got to work was using the full City,State (No Space) as my location. What helped me was going to the openweather site and typing in different combinations until I found the one that was for my city which according to them there are 6 different city’s in the US with that name.

    For Philadelphia what works is Philadelphia,Pennsylvania (Note there is NO SPACE between the city and state)
    http://openweathermap.org/city/4560349

    unfortunately, it didnt work as seen by the screenshot below. i wonder if it is because the files are hosted on a webserver located in another city. all of Teeuw’s files are located on a bluehost.com server. the autostart file on the rpi tells Chromium to load this website http://dablet.com/tung_quote/

    0_1463135378549_mirror 2.jpg


  • MagicMirror Creator

    Is it incorrect from the start? Or after a while? If it’s after a while (a day) is’t because it doesn’t get updated. (Maybe because of a connection problem)


  • Moderator

    "all of Teeuw’s files are located on a bluehost.com server."
    

    That doesn’t make any difference. MM doesn’t actively use any of those files. When you installed MM, it copied everything locally. The only time it fetches data, is when the modules are triggered, and they go to where you tell them. For example, the weather module goes to fetch the city you tell it to. The time display is based on your rPi setup, that has nothing to do with MM.

    When you first setup your rPi, did you go through the localization setup as well? Telling it what timezone you’re in, what language to use, keyboard, WiFi country … all of those things you need to set, and are completely unrelated to MM, or any other application you run on it. However, they do affect what gets displayed, again, both through MM, or any other application. If the application uses the rPi’s locale, and sees that you have it set to Zimbabwe, it will happily adjust the time for that.



  • good morning, here is my rpi setup.
    for locale, it has en_GB ( I dont think this matters, but what is the value for USA?)
    for timezone, it is already New York.
    the rpi and my PC shows the same info when i go to this website : http://dablet.com/tung_quote/
    the reason i have the rpi loads that website is because i can change the content as needed remotely. i dont have to visit the person’s house and log into putty locally to make changes.
    @KirAsh4 0_1463223111108_mirror 3.jpg


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.