MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-AssistantMk2 problems when using electron-rebuild



  • When I start my magic mirror I get node version error so I did as the instructions told me and tried using electron-rebuild. But when I use electron-rebuild I get this error:

    make: *** Ingen regel för att skapa målet ”Release/obj.target/grpc/deps/grpc/src/cpp/ext/filters/census/grpc_context.o”, som behövs av ”Release/obj.target/libgrpc.a”.  Stannar.
    make: Lämnar katalogen ”/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/build”
    gyp ERR! build error 
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/node-gyp/lib/build.js:262:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:180:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
    gyp ERR! System Linux 4.14.52-v7+
    gyp ERR! command "/usr/bin/node" "/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/.bin/node-gyp" "rebuild" "--target=2.0.0" "--arch=arm" "--dist-url=https://atom.io/download/electron" "--build-from-source" "--module_name=grpc_node" "--module_path=/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v2.0-linux-arm-glibc" "--host=https://node-precompiled-binaries.grpc.io/" "--remote_path={name}/v1.14.0" "--package_name=electron-v2.0-linux-arm-glibc.tar.gz"
    gyp ERR! cwd /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc
    gyp ERR! node -v v9.11.2
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok 
    
    Failed with exit code: 1
        at SafeSubscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/spawn-rx/lib/src/index.js:277:84)
        at SafeSubscriber.__tryOrUnsub (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:242:16)
        at SafeSubscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:201:26)
        at Subscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:132:26)
        at Subscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:106:18)
        at MapSubscriber.Subscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:132:26)
        at MapSubscriber.Subscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:106:18)
        at SafeSubscriber._next (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/spawn-rx/lib/src/index.js:251:65)
        at SafeSubscriber.__tryOrSetError (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:251:16)
        at SafeSubscriber.next (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:191:27)
    

    Excuse the Swedish parts.

    What do I do to make it work?


  • Module Developer

    @xintium

    It seems you’ve missed some dependencies or mismatched version (especially node-gyp)

    First, To make things simple, do these before install,

    sudo apt-get update
    sudo apt-get upgrade
    

    and try rebuilding again.

    If fails, remove whole MMM-AssistantMk2, and resintall from scratch.



  • @sean should I run

    npm install --save-dev electron-rebuild
    ./node_modules/.bin/electron-rebuild
    

    In MMM-AssistantMk2 or in MagicMirror directory?


  • Module Developer

    @xintium
    In MMM-AssistankMk2 directory.



  • @sean I get the same error as I shared abow



  • @sean This is what I get when I run magic mirror

    
    > magicmirror@2.4.1 start /home/pi/MagicMirror
    > sh run-start.sh
    
    Starting MagicMirror: v2.4.1
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    No helper found for module: MMM-darksky-hourly.
    Initializing new module helper ...
    Module helper loaded: MMM-MyCalendar
    WARNING! Could not load config file. Starting with default configuration. Error found: Error: Failed to load gRPC binary module because it was not installed for the current system
    Expected directory: electron-v2.0-linux-arm-glibc
    Found: [node-v59-linux-arm-glibc]
    This problem can often be fixed by running "npm rebuild" on the current system
    Original error: Cannot find module '/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v2.0-linux-arm-glibc/grpc_node.node'
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    No helper found for module: MMM-darksky-hourly.
    Initializing new module helper ...
    Module helper loaded: MMM-MyCalendar
    App threw an error during load
    Error: Failed to load gRPC binary module because it was not installed for the current system
    Expected directory: electron-v2.0-linux-arm-glibc
    Found: [node-v59-linux-arm-glibc]
    This problem can often be fixed by running "npm rebuild" on the current system
    Original error: Cannot find module '/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v2.0-linux-arm-glibc/grpc_node.node'
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/grpc_extension.js:53:17)
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/grpc_extension.js:63:3)
        at Module._compile (module.js:642:30)
        at Object.Module._extensions..js (module.js:653:10)
        at Module.load (module.js:561:32)
        at tryModuleLoad (module.js:504:12)
        at Function.Module._load (module.js:496:3)
        at Module.require (module.js:586:17)
        at require (internal/module.js:11:18)
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:145:12)
    Whoops! There was an uncaught exception...
    { Error: Failed to load gRPC binary module because it was not installed for the current system
    Expected directory: electron-v2.0-linux-arm-glibc
    Found: [node-v59-linux-arm-glibc]
    This problem can often be fixed by running "npm rebuild" on the current system
    Original error: Cannot find module '/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v2.0-linux-arm-glibc/grpc_node.node'
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/grpc_extension.js:53:17)
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/grpc_extension.js:63:3)
        at Module._compile (module.js:642:30)
        at Object.Module._extensions..js (module.js:653:10)
        at Module.load (module.js:561:32)
        at tryModuleLoad (module.js:504:12)
        at Function.Module._load (module.js:496:3)
        at Module.require (module.js:586:17)
        at require (internal/module.js:11:18)
        at Object. (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:145:12) code: 'MODULE_NOT_FOUND' }
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Launching application.
    

  • Module Developer

    @xintium
    You need module to rebuild.

    npm install --save-dev electron-rebuild
    ./node_modules/.bin/electron-rebuild
    

    If you tried already, something was wrong so rebuilding process might have been failed.
    Have you any suspicious messages during your rebuilds?



  • @sean I get this message when trying to use electron-rebuild

    make: *** Ingen regel för att skapa målet ”Release/obj.target/grpc/deps/grpc/src/cpp/ext/filters/census/grpc_context.o”, som behövs av ”Release/obj.target/libgrpc.a”.  Stannar.
    make: Lämnar katalogen ”/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/build”
    gyp ERR! build error 
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/node-gyp/lib/build.js:262:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:180:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
    gyp ERR! System Linux 4.14.52-v7+
    gyp ERR! command "/usr/bin/node" "/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/.bin/node-gyp" "rebuild" "--target=2.0.0" "--arch=arm" "--dist-url=https://atom.io/download/electron" "--build-from-source" "--module_name=grpc_node" "--module_path=/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v2.0-linux-arm-glibc" "--host=https://node-precompiled-binaries.grpc.io/" "--remote_path={name}/v1.14.0" "--package_name=electron-v2.0-linux-arm-glibc.tar.gz"
    gyp ERR! cwd /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc
    gyp ERR! node -v v9.11.2
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok 
    
    Failed with exit code: 1
        at SafeSubscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/spawn-rx/lib/src/index.js:277:84)
        at SafeSubscriber.__tryOrUnsub (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:242:16)
        at SafeSubscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:201:26)
        at Subscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:132:26)
        at Subscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:106:18)
        at MapSubscriber.Subscriber._error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:132:26)
        at MapSubscriber.Subscriber.error (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:106:18)
        at SafeSubscriber._next (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/spawn-rx/lib/src/index.js:251:65)
        at SafeSubscriber.__tryOrSetError (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:251:16)
        at SafeSubscriber.next (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/rxjs/Subscriber.js:191:27)
    

  • Module Developer

    @xintium
    For confirmation,

    1. Did you update & upgrade dependencies?
    2. After that, did you remove MMM-AssistantMk2 directory and reinstall again?

    Your error shows some of your dependencies are not updated to rebuild.
    In that case, usually above steps are enough to fix.

    Maybe this might be a help, but not sure.

    sudo apt-get install build-essential 
    sudo npm install -g node-gyp
    


  • Hello!

    I have this error, when trying to run the node_auth_test.js

    Error: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/node-v48-linux-arm-glibc/grpc_node.node)

    Can you give some advise how to solve this?
    Thanks