MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Strange Glitching on HDMI



  • Hi All,

    I’m asking this question here for advice on how to proceed as much as seeking a solution.

    I’ve recently installed Magic Mirror on a Pi 3 B+ (brand new, first install on this Pi). I flashed Raspbian using Etcher and installed MM from the auto install. I installed the fkms OpenGL and set the config to rotate_display 3. I installed the MMM-PIR-Sensor module and played around with this, but couldn’t get it working - in the end I removed this from the config, but didn’t remove any components of the module. All else is working okay, except the transitions of the text on the screen is a bit jerky. I checked the temperature of the Pi from a console command and it was 58.

    My major issue is though, that I’m occasionally getting what I can only describe as a HDMI crash - I get a scrolling diagonal black and white glitched screen. I think this is on HDMI only, as on the second time it happened I switched the HDMI to a second screen and the error displayed in the same way on a second screen. I was also able to connect via VNC to the pi and the VNC session didn’t display the same problem while the problem was visible on the monitor.

    One thing that I will stipulate is that when I started working on the build, I had the pi powered from the USB ports on the monitor - when I started troubleshooting the PIR problem, I noticed the 5V rail was only supplying 4.8v, so I have operated in an under powered state for many steps - I’ve plugged in a pi3 power supply now. (The 2.5amp ones)

    So, opinions please - I’m thinking I might just need to start again, forget the MMM-PIR-Sensor module (use some Python for that) and see how I get on.

    Is the fkms option a good choice, or should I have gone the other suggested route and used the kms openGL?

    Or, has anyone else had this issue with the HDMI and know a fix?

    Or, could this be a hardware problem (even one I’ve caused under powering)?

    Thanks all - I appreciate it.



  • @stickyrib with the 2.4 release a heating problem arose with heavy cpu usage due to electron. Is was adviced tot use the fkms (see post michael). When i followed up on this post both alternatives did not work out for me. One option got me star night like flickering in the widgets on screen, the other led to what you described. So I returned to the driver which was used up unto 2.3.
    Never thought about powering via the monitor to be the probleproblem/solution, but I do connect it that way.

    So still on default screen driver and no heating problem and no flickering.



  • I have that Problem too…
    Any tip for me why the Fake driver Not work??



  • If i use the kfm driver. All okay …
    Only Problem ist tvservice -p dont work
    But
    vcgencmd display_power 0
    and
    vcgencmd display_power 1
    works.

    The MMM-PIR Senor Modul use
    Vvgencmd so all is Fine for me.

    I Hope. My Sensor will Come on monday



  • Had a similar problem a couple of months ago. Following the instructions on MagicMirror Wiki page, I enabled the Full KMS OpenGL driver instead of using the fake one. As my setup is vertically mounted, I used xrandr to rotate the display.
    Finally, installed a cooling fan on Raspberry Pi. No problem since then.



  • Thanks everyone - I have a few days off, so have restarted my build - so far so good, but it’s early days.

    Have enabled the Full KMS, rather than the fake, and rotated using xrandr - hopefully that will keep it stable.

    I really appreciate the feedback.



  • So, I’ve got the mirror rebuilt and it’s working really well.
    I haven’t gone near the PIR sensor yet, but plan to back up the SD Card in the state I have it now and come back to it if needed.
    In short, I have the standard modules working in a portrait rotated position running on the official KMS OpenGL driver and it’s transitioning smoothly and without the glitching.

    One thing that has occurred to me, during my first build I was using the overscan_left=16 options from within config.txt - I know that the rotate_lcd=1 option works in FKMS, but I’m throwing it out there that the problem I had might have been the overscan options in conjunction with the FKMS OpenGL driver - I haven’t tested this, but thought I’d comment here for others who might visit this thread in the future.