MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-SunRiseSet Suddenly not displaying image



  • @Mykle1

    I have the module MMM-SunRiseSet installed and it suddenly stopped displaying the image. Instead I get the placeholder text. Nothing was changed on my mirror and this module was working fine for the past week or so. Does anyone have suggestions around how too resolve this?
    Notes:

    1. I have a cron job restarting MagicMirror every 5 hours (the Mirror display hangs at a black screen otherwise)
    2. I performed a reboot and the problem persists.
    3. I tried changing the config to have it display something else.
    4. I removed the MMM-SunRiseSet directory from the modules directory and re-cloned and reloaded the modules, still no effect. I then rebooted and it’s still not displaying.
    5. Removed one of the entries in the config.js to show only one image. Rebooted. Still nothing.

    Should I try an older build of Magic Mirror? The current one seems to have issues.
    Here is my config and a screenshot of what I am seeing. (I am running two instances of the module to show both sides of the planet.

    {
    	disabled: false,
    	module: "MMM-SunRiseSet",
    	position: "bottom_left",
    	config: {
    		lat: "###",      // Your latitude (for the data)
    		lng: "###",     // Your longitude (for the data)
    		image: "world",          // "world" (animation), "map" (animation), "static" (graph)
    		imageOnly: "yes",       // no = all data, yes = only animated world or map
    		dayOrNight: "day",   // "night" approaching, "day" approaching (imageOnly: must be "yes", image: must be "world") 
    		useHeader: false,      // true if you want a header
    		header: "Header",      // useHeader must be true
    		maxWidth: "300px",
        }
    },
    {
            disabled: false,
            module: "MMM-SunRiseSet",
            position: "bottom_right",
            config: {
                    lat: "###",      // Your latitude (for the data)
                    lng: "###",     // Your longitude (for the data)
                    image: "world",          // "world" (animation), "map" (animation), "static" (graph)
                    imageOnly: "yes",       // no = all data, yes = only animated world or map
                    dayOrNight: "night",   // "night" approaching, "day" approaching (imageOnly: must be "yes", image: must be "world")
                    useHeader: false,      // true if you want a header
                    header: "Header",      // useHeader must be true
                    maxWidth: "300px",
        }
    },
    

    0_1540062708093_Screen Shot 2018-10-20 at 2.59.59 PM.png



  • Never mind. The images suddenly started loading. That’s very odd.


  • Module Developer

    @striiker said in MMM-SunRiseSet Suddenly not displaying image:

    Never mind. The images suddenly started loading. That’s very odd.

    I fixed it “Magically” 🙂

    It is somewhat likely that the data the module is fetching was unavailable for a while. I’m glad it is working for you once again. You’re using two instances? That makes me twice as happy. I hope you’re enjoying it. 👍