MagicMirror² v2.6.0 is available! For more information about this release, check out this topic.

Troubles updating to 2.6.0



  • I ran into troubles when updating to 2.6.0, before on 2.5.0 everything worked fine.

    I get errors when update with git pull && npm install, below the npm debug_log

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@1.4.21
    3 info using node@v8.11.1
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info prestart magicmirror@2.6.0
    6 info start magicmirror@2.6.0
    7 verbose unsafe-perm in lifecycle true
    8 info magicmirror@2.6.0 Failed to exec start script
    9 error magicmirror@2.6.0 start: `sh run-start.sh`
    9 error Exit status 127
    10 error Failed at the magicmirror@2.6.0 start script.
    10 error This is most likely a problem with the magicmirror package,
    10 error not with npm itself.
    10 error Tell the author that this fails on your system:
    10 error     sh run-start.sh
    10 error You can get their info via:
    10 error     npm owner ls magicmirror
    10 error There is likely additional logging output above.
    11 error System Linux 4.14.90-v7+
    12 error command "/usr/bin/node" "/usr/bin/npm" "start"
    13 error cwd /home/pi/MagicMirror
    14 error node -v v8.11.1
    15 error npm -v 1.4.21
    16 error code ELIFECYCLE
    17 verbose exit [ 1, true ]
    

    when I manually try to start via npm start it states that

    > magicmirror@2.6.0 start /home/pi/MagicMirror
    > sh run-start.sh
    
    run-start.sh: 4: run-start.sh: electron: not found
    

    so I tried to install/update electon but had no luck

    npm ERR! Error: Method Not Allowed
    npm ERR!     at errorResponse (/usr/share/npm/lib/cache/add-named.js:260:10)
    npm ERR!     at /usr/share/npm/lib/cache/add-named.js:203:12
    npm ERR!     at saved (/usr/share/npm/node_modules/npm-registry-client/lib/get.js:167:7)
    npm ERR!     at FSReqWrap.oncomplete (fs.js:135:15)
    npm ERR! If you need help, you may report this *entire* log,
    npm ERR! including the npm and node versions, at:
    npm ERR!     
    
    npm ERR! System Linux 4.14.90-v7+
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "i" "electron"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v8.11.1
    npm ERR! npm -v 1.4.21
    npm ERR! code E405
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    

    what am I missing?



  • @azuettel - What command did you use to update Electron?



  • @azuettel u are running a very old version of npm, 1.x

    Should be v 6 at least.


  • Module Developer

    Your version of npm is way too old - install the latest version through the terminal:
    sudo npm install -g npm



  • @bhepler

    npm install electron@latest