MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Stuck on creating a new fetcher



  • Hello,

    I recently installed MM on a Pi 3, and for some reason I can’t make it past this point. I tried removing the NYT module and it got stuck on the holidays iCal. Do I need to adjust the interval to force it sooner? I wouldn’t think so, but I’m not sure. Any suggestions would be greatly appreciated.

    Edit: I should add, this is with default config.js file (after renaming from config.js.sample)

    Edit 2: ran the check_config.js and it says my configuration file doesn’t contain syntax errors.

    alt text


  • Module Developer

    DISPLAY=:0 meansyou have a screen at which you show the interface, what do you see on that screen, nothing? I haven’t install MM for a while, is there a log file by any change in the root MM folder?

    Try to run in dev mode, might give you more information

    npm start dev
    


  • there is a bug on some OS’s, which I ran into last night… try this

    npm start 2>/dev/null
    

    it fixes my hang in about the same place…with the default config



  • @ultimatum22 I’m not sure what you mean. Doesn’t 'DISPLAY=:0" mean the attached display? I’ve got the Pi hooked up to a 24" TV display.



  • @sdetweil No luck on this side. I may just do a reinstall at this point. Not sure what’s causing the hangup


  • Module Developer

    @cotxwx When you start the MM and it hangs try to access the webpage through another computer/phone. Go to <:8080 (I believe it was). If you are able to see the MM then it correctly starts (this is my assumption).

    If it doesn’t work can you try to just run npm start without the DISPLAY=:0.


Log in to reply