Error on start



  • When starting with the “node serveronly” (I can’t get npm to launch electron for some reason), I get this error:
    pi@raspberrypi:~/MagicMirror $ node serveronly
    Loading config …
    WARNING! Could not load config file. Starting with default configuration. Error found: TypeError: Object # has no method 'accessSync’
    Loading module helpers …
    No helper found for module: helloworld.
    All module helpers loaded.
    Starting server op port 8080 …
    Server started …
    Sockets connected & modules started …

    Ready to go! Please point your browser to: http://localhost:8080

    I don’t understand why it won’t use my config. The config is identical to the sample one that its in the config folder.



  • @negativeflare There are a couple things to check. For starters, make sure that you copied the config.js.sample to config.js. All lowercase. And it must be in the ~/MagicMirror/config folder.

    Assuming those are true, copy & paste your config.js in this thread, using the markdown commands. We’ll take a look at it and see if we notice anything.



  • I am also having this exact same problem. Also when trying to run as server only. The config.js file is correctly named and in the correct location. I have not changed the content at all. When I look at the browser, all of the modules just say “Loading …”.
    Any ideas?



  • @04housemat What version of the Pi do you have and how did you install MagicMirror?

    While you’re at it, head over www.openweathermap.com and 1) get an API key, and 2) find the location # for where you wish to see the current weather conditions and forecast. These need to go into the config.js file.



  • @bhepler Thanks for your reply! Its a raspberry pi zero. I downloaded the zip from github, followed the manual install instructions. "Enter the repository: cd ~/MagicMirror, Install and run the app: npm install && npm start. "
    Seems to be working ok, just not loading the config. I’ve updated the file with these details now :)



  • @negativeflare I had this error as well after setting up on a Raspberry Pi (1) only yesterday and running as serveronly.

    I found that to fix this I had to upgrade node, as doing an apt-get install for node gave me version 0.10.x or something like that.

    I followed this script up to line 26.
    https://github.com/audstanley/Node-MongoDb-Pi/blob/master/Install-Node-MongoDb-Pi.sh

    But I changed it to the arm6l and version 5 of node.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.