MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

MMM-ISS and Daily XKCD - Can't get these modules working



  • Hi -
    First post. Been having a blast setting up MagicMirror - thanks to all the devs and the help they post.

    I have had a lot of success with various modules, but occasionally, I run into one that gives me trouble. These two (MMM-ISS and DailyXKCD) - i just can’t figure out whats going wrong. I’m not getting any syntax errors, my other modules load up fine, and even when I remove all other modules, these two still don’t appear for me. I’ve also tried different positions.
    DailyXKCD just does not appear on screen at all.
    MMM-ISS does show up, but only reads “Is that the ISS?” on screen, no other info.

    I was hoping for any help on these two specifically, where I may be going wrong.
    Also hoping for any advice on steps to take when this happens with modules, aside from disabling other modules, and trying it out, etc. I am reading through the “How to Troubleshoot” post, trying to help myself.

    Thanks again.


  • Project Sponsor Module Developer

    @Swashbucklin

    I can help you with MMM-ISS. I just cloned the repo into my MagicMirror/modules folder. Then I copied and pasted the example config entry from the repo into my config.js file. I can assure you that it is working as intended.

    Have you made any changes to the module files? And, kindly post your config entry for this module, like so:

      {
           disabled: false,
           module: 'MMM-ISS',
           position: 'top_right',
    	   config: {
    		   country: "United_States",                  // NO SPACES, USE UNDERSCORE
    		   regionState: "New_York",                   // NO SPACES, USE UNDERSCORE
    		   city: "Staten_Island",                            // NO SPACES, USE UNDERSCORE
    		   lat: "40.00",                              // latitude
    		   lng: "-74.00",                             // longitude
    		   units: "mi",                               // mi = miles, mph / km = kilometers, km/h
    		   useHeader: false,                          // true if you want a header
    		   header: "",                                // Any text you want. useHeader must be true
    		   updateInterval: 20 * 1000,
    	}
    },
    


  • Hi, and thanks for the response. I just want to mention that over the last several weeks, as I’ve been working through this project, all your posts and explanations and guides have been incredibly helpful. Your modules are awesome, too.

    I have not made any changes, just cloned and copy/pasted into config. I originally did not have that disabled: false line, but even adding that in has not helped.
    All i see is “Is that the ISS?” but no other info or graphics. It has to be something on my end - as you say, i’m sure that the module is working as intended.
    Here’s my entire entry for the “troubleshoot config” I’m working with.

    modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			disabled: false,
               		module: 'MMM-ISS',
               		position: 'top_right',
    		   	config: {
    			   country: "United_States",                  // NO SPACES, USE UNDERSCORE
    			   regionState: "New_York",                   // NO SPACES, USE UNDERSCORE
    			   city: "Staten_Island",                     // NO SPACES, USE UNDERSCORE
    			   lat: "40.00",                              // latitude
    			   lng: "-74.00",                             // longitude
    			   units: "mi",                               // mi = miles, mph / km = kilometers, km/h
    			   useHeader: false,                          // true if you want a header      
    			   header: "",                                // Any text you want. useHeader must be true
    			   updateInterval: 20 * 1000,
    			}
    		}
    	]
    

  • Project Sponsor Module Developer

    @Swashbucklin

    I don’t know what the rest of your troubleshooting config looks like so I duplicated yours along with the rest of the config. Again, it fires right up for me without any problems. Please try to copy and paste this ENTIRE example, saving it as config.js and run MM to see what happens. If it fails then your problem is elsewhere. Are you seeing any errors in the terminal or the dev console when yours doesn’t work?

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information how you can configurate this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 12,
    	units: "imperial",
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			disabled: false,
            module: 'MMM-ISS',
            position: 'top_right',
    		   	config: {
    					   country: "United_States",                  // NO SPACES, USE UNDERSCORE
    					   regionState: "New_York",                   // NO SPACES, USE UNDERSCORE
    					   city: "Staten_Island",                     // NO SPACES, USE UNDERSCORE
    					   lat: "40.00",                              // latitude
    					   lng: "-74.00",                             // longitude
    					   units: "mi",                               // mi = miles, mph / km = kilometers, km/h
    					   useHeader: false,                          // true if you want a header
    					   header: "",                                // Any text you want. useHeader must be true
    					   updateInterval: 60 * 1000,
    			}
    		}
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    

  • Project Sponsor Module Developer

    Using the config I posted above

    0_1552098108362_S.png



  • I got it. I’m gonna chalk this one up to a lesson learned for a noob. You see, I was refreshing MagicMirror by simply x’ing out the window. I decided to do a pm2 restart and bingo… that did the trick. The graphic comes up with any config file I run.
    I had a feeling it was something dumb I was doing. Appreciate your support - I’m going to be working on installing/personalizing Hello Lucy next.


  • Project Sponsor Module Developer

    @Swashbucklin

    Glad you got it working! 👍