MMM-Spotify



  • @Sean I have changed the hook phrase to “showtime” and it still doesn’t work.

    SPOTIFY_PLAY: {
        pattern : "showtime",
        command: "SPOTIFY_PLAY"
      },
    
    [HOTWORD] Final Result: { detected: true, hotword: 'assistant', file: null }
    [AMK2] assistant ready
    [AMK2] Conversation starts.
    [AMK2] Assistant Text Response:
    [AMK2] Transcription: show  --- Done: false
    [AMK2] Transcription: shut  --- Done: false
    [AMK2] Transcription: showtime  --- Done: false
    [AMK2] Transcription: showtime  --- Done: false
    [AMK2] end-of-utterance
    [AMK2] Transcription: showtime  --- Done: true
    { requestId: '5d433446-0000-2772-8141-089e0827c3f4' } { profileFile: 'default.json', lang: 'en-US' }
    [AMK2] Device Action: { requestId: '5d433446-0000-2772-8141-089e0827c3f4' }
    [AMK2] Assistant Text Response:
    [AMK2] Conversation Completed
    null
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    


  • This post is deleted!

  • Module Developer

    @menanr
    Check your firewall or network setting. And check also your MM is running on port 8888. You can try to connect “https://localhost:8888/callback” outside of your home network to check whether it is accessible from outside.



  • i can only see spotify logo and hear music . But nothing to show !!
    What can i do ? and how to config onStart: { ??
    Here is error logs

    [AMK2] Temporal storage directory is clearing.
    Whoops! There was an uncaught exception…
    TypeError: Cannot read property ‘getCurrentPlayback’ of null
    at Class.updatePulse (/home/pi/MagicMirror/modules/MMM-Spotify/node_helper.js:30:18)
    at Class.initAfterLoading (/home/pi/MagicMirror/modules/MMM-Spotify/node_helper.js:26:10)
    at Class.socketNotificationReceived (/home/pi/MagicMirror/modules/MMM-Spotify/node_helper.js:44:12)
    at Socket. (/home/pi/MagicMirror/modules/node_modules/node_helper/index.js:113:11)
    at Socket.emit (events.js:182:13)
    at /home/pi/MagicMirror/node_modules/socket.io/lib/socket.js:528:12
    at process._tickCallback (internal/process/next_tick.js:61:11)


  • Module Developer

    @t-architecture99
    Maybe your ‘spotify.config.json’ would be wrong. Check it again.



  • @brokenwings

    Hi did you figure this out, I’m stuck at this very same issue, I have Spotify working . how do I get voice assistant to integrate, do I modify the config.js file or the AssistantMK2.json file…??



  • Having an issue with the song info showing up on the MM.
    I have everything installed correctly ( to my knowledge, or else it would work right?) and have the white Spotify symbol.
    I entered my Client ID and Secret.
    Callback and port are in there. I authorized through Spotify…
    Not sure what i am missing…

    Help?

    {
      			module: "MMM-Spotify",
      			position: "bottom_left",
      			config: {
        				style: "mini", // "default" or "mini" available
        				control: "default", //"default", "hidden" available
        				updateInterval: 1000,
        				onStart: null, // disable onStart feature with `null`
        				allowDevices: [], //If you want to limit devices to display info, use this.
        				// allowDevices: ["RASPOTIFY", "My iPhoneX", "My Home speaker"],
      				}
    		},
    
    {
      "CLIENT_ID" : "xxxx",
      "CLIENT_SECRET" : "xxxx",
      "AUTH_DOMAIN" : "http://localhost",
      "AUTH_PATH" : "/callback",
      "AUTH_PORT" : "8888",
      "SCOPE" : "user-read-private app-remote-control playlist-read-private streaming user-read-playback-state user-modify-playback-state",
      "TOKEN" : "./token.json"
    }
    

  • Module Developer

    @bminer1
    Tell me more details. What happens on MagicMirror when you activate your spotify app on your smartphone?



  • @Sean i restarted the pi and my computer that is running the spotify. Everything is running and working as it should. buttons work, displays very well and its all good. Sorry, for the false alarm. noob moment.



  • Love the module, but noticed it makes the mirror by far the noisiest device on my network. Any idea why it talks so much to the spotify api?
    0_1575557767870_pihole-domains.png
    0_1575557775582_pihole-clients.png