MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

Wish i never updated to 2.7.1 Black Screen!



  • @sdetweil right thanks here it is

    pi@raspberrypi:~/MagicMirror $ npm start &
    [1] 1486
    pi@raspberrypi:~/MagicMirror $ 
    > magicmirror@2.6.0 start /home/pi/MagicMirror
    > sh run-start.sh
    
    Starting MagicMirror: v2.6.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: MMM-pages.
    No helper found for module: MMM-page-indicator.
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control-Repository
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control
    No helper found for module: clock.
    WARNING! Could not load config file. Starting with default configuration. Error found: Error: Cannot find module 'lmtool'
    Loading module helpers ...
    No helper found for module: MMM-pages.
    No helper found for module: MMM-page-indicator.
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control-Repository
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control
    No helper found for module: clock.
    App threw an error during load
    Error: Cannot find module 'lmtool'
        at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (internal/modules/cjs/loader.js:528:25)
        at Module.require (internal/modules/cjs/loader.js:658:17)
        at require (internal/modules/cjs/helpers.js:20:18)
        at Object. (/home/pi/MagicMirror/modules/MMM-voice/node_helper.js:32:16)
        at Object. (/home/pi/MagicMirror/modules/MMM-voice/node_helper.js:373:3)
        at Module._compile (internal/modules/cjs/loader.js:711:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:722:10)
        at Module.load (internal/modules/cjs/loader.js:620:32)
    Whoops! There was an uncaught exception...
    { Error: Cannot find module 'lmtool'
        at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (internal/modules/cjs/loader.js:528:25)
        at Module.require (internal/modules/cjs/loader.js:658:17)
        at require (internal/modules/cjs/helpers.js:20:18)
        at Object. (/home/pi/MagicMirror/modules/MMM-voice/node_helper.js:32:16)
        at Object. (/home/pi/MagicMirror/modules/MMM-voice/node_helper.js:373:3)
        at Module._compile (internal/modules/cjs/loader.js:711:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:722:10)
        at Module.load (internal/modules/cjs/loader.js:620:32) code: 'MODULE_NOT_FOUND' }
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Launching application.
    
    
    


  • @dazza120 ok, just want to check again…

    after doing the git pull in the MM folder
    you then
    did npm install while in the MM folder, right? you must

    as you have MMM-voice installed
    u need to do npm install there too



  • @sdetweil Hi yes i done that but for some reason its stayed on 2.6.0 and said that was the latest version is there anyway to push it to install the latest version i have done git hard rest but dont know where to go form there.



  • @dazza120 git reset hard blows you back to the last time u did a git pull

    then u do a git pull to get the latest
    then npm install
    then npm install in any module folder that has a package.json file

    snowboy (MMM-voice and MMM-Hotword) is a pain in the rear…
    usually requires a special command (electron-rebuild) to rebuild some part at the new electron level…
    see instructions in MMM-Hotword



  • @sdetweil Yeah it isn’t installing the new MM it says its on the latest version 2.6.0 not 2.7.1 I get to this HEAD is now at b508a62 Merge pull request #1632 from MichMich/fix-2.7.1 and then when i do git pull it says its already on the latest 😞



  • @dazza120 edit the MM/package.json
    what version is there?? should say 2.8-develop

    also show me the results of git remote -v
    is your git copy of a fork you might have made?



  • @sdetweil thanks for your help I’m sorted now apart from Calendar not coming up with dates, I saved the config so it was just a case of re downloading everything again 😞



  • @dazza120 glad u r working ok



  • @dazza120 could u mark your issues solved… thx