MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Help with Update to 2.7.0



  • Sorry if this is an obvious question. I tried to update to 2.7.0.

    From the MagicMirror folder, I type git pull && npm install

    But the only response I see is “Updating de57daa…b508a62”. The I get the prompt back in a couple seconds.



  • @Kenny try it one at a time

    git pull
    

    then

    npm install
    


  • @sdetweil : Thanks. I gave that a try.

    git pull

    Updating de57daa…b508a62

    npm install

    [installs MagicMirror 2.6.0]



  • @Kenny could u do

    git remote -v




  • Project Sponsor

    Run the following command in the MagicMirror folder

    rm package-lock.json
    rm vendor/package-lock.json 
    

    Then execute in the folder the usual command for the upload

    git pull && npm install
    

    Now it should work



  • Thanks for the help @sdetweil and @CyruS1337. The latest suggestion gave me the same "Updating … " response.

    I just renamed my MagicMirror folder and did a clean install. Everything is working great again. THANKS!



  • @CyruS1337 said in Help with Update to 2.7.0:

    Run the following command in the MagicMirror folder

    rm package-lock.json
    rm vendor/package-lock.json 
    

    Then execute in the folder the usual command for the upload

    git pull && npm install
    

    Now it should work

    @CyruS1337 this solved the firt install command but…

    ownloading tmp-2822-0-electron-v3.0.13-linux-armv7l.zip
    Error: read ECONNRESET
    /home/pi/MagicMirror/node_modules/electron/install.js:49
      throw err
      ^
    
    Error: read ECONNRESET
        at TLSWrap.onStreamRead (internal/stream_base_commons.js:111:27)
    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! electron@3.0.13 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@3.0.13 postinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-04-05T19_09_38_688Z-debug.log
    pi@raspberrypi:~/MagicMirror $ 
    pi@raspberrypi:~/MagicMirror $ npm start
    
    > magicmirror@2.7.1 start /home/pi/MagicMirror
    > sh run-start.sh
    
    run-start.sh: 4: run-start.sh: electron: not found
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.7.1 start: `sh run-start.sh`
    npm ERR! spawn ENOENT
    npm ERR! 
    npm ERR! Failed at the magicmirror@2.7.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    

    if an idea
    thanks
    Jean-Philippe


  • Project Sponsor

    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ git remote -v
    origin	https://github.com/MichMich/MagicMirror.git (fetch)
    origin	https://github.com/MichMich/MagicMirror.git (push)
    pi@raspberrypi:~/MagicMirror $ 
    pi@raspberrypi:~/MagicMirror $ rm package-lock.json
    pi@raspberrypi:~/MagicMirror $ rm vendor/package-lock.json 
    pi@raspberrypi:~/MagicMirror $ git pull && npm install
    Updating de57daa..b508a62
    pi@raspberrypi:~/MagicMirror $ 
    
    

    Still have the same issue and can’t update…any help would be appreciated.



  • @swvalenti said in Help with Update to 2.7.0:

    git pull && npm install

    ok, lets try this

    git stash
    git pull
    

    if ok, then npm install