MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Raspberry pi model 3 b+ not powering up

  • hey, guys i need help . so my raspberry pi was hooked to my mirror frame last week Wednesday and everything was working fine. i decided to turn it off later that day and ever since then i haven’t tried to put on the mirror. however i tried to put on the mirror today and i got a blank screen. so i removed the raspberry pi and disconnected everything connected to the gpio. i tried to power on the raspberry pi with nothing attached to it using its official power cable which has a push button on it.

    long story short, the raspberry pi did not power up and there are no lights on the board (usually there is a red and a green light). there is nothing happening and the raspberry appears to be dead but i realized there is a little bit of heat on the power port on Pi.

    the power cable works fine because i tried charging my phone with it and it worked.

    please do you guys know what is going on and how do i solve this problem. please help its urgent.

  • Project Sponsor Module Developer

    When you turned it off before, how did you power down the pi? Did you use the inline power button in the power cable? If so, it’s possible that the card might have been corrupted. If you have a known good backup, I would try flashing that back to the card to see if it boots. I don’t know why the power supply includes a push button switch, as this is a known way to mess things up. It’s best to SSH in and use the command sudo shutdown instead, or wire up a momentary switch to the GPIO that runs a script to execute that command.

    However the fact that you say that not even the red light comes on leads me to believe there is a larger problem, and the board might indeed be dead. If you have a spare SD card lying around, try flashing NOOBS on it and see if that boots.

Log in to reply