MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Please create a config file



  • I have a config file. i tried to add the remote control module exactly like it says on the github page, and it never works…works fine with the sample config. any ideas before i scrub it?



  • @jiminsav sorry, i don’t understand what you said.

    i tried to add the remote control module exactly like it says on the github page, and it never works
    

    but then you said

    works fine with the sample config. 
    

    so it does work… like the doc says (sample config)…

    so, what is the next thing you are trying to do… so the config (please use the markdown feature to organize the stuff you post)… three backtics before (ket to left of number 1) and 3 backtics after



  • what i am trying to express, is that Magic Mirror works fine out the box, but when i add the remote module, and edit the config.js file, the magic Mirror shows “please add a config file” when it starts. if i then use the backup and rename it to Config.js, the program works fine.
    i add the module info EXACTLY as it shows in the Github page for the remote control module, and it does not work. i copy and pasted a few examples from this forum, it still does not start Magic Mirror. at this point, it’s pretty worthless if i can’t remote access it.


  • Project Sponsor

    @jiminsav - It sounds like there’s an error in the module configuration. So let’s solve that.

    Please copy & paste the module configuration here, using the markdown features. We’ll look it over and see if we can spot the problem.

    The other technique is to run the config checker that is included in the module. Change to your Magic Mirror folder and run npm run config:check



  • @jiminsav yes, the MMM-Remote-Control module text has an error…

    {
        module: 'MMM-Remote-Control'   // < ---- missing comma, add it
        // uncomment the following line to show the URL of the remote control on the mirror
        //  position: 'bottom_left',
        // you can hide this module afterwards from the remote control itself
        config: {
            customCommand: {},  // Optional, See "Using Custom Commands" below
            customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
            showModuleApiMenu: true, // Optional, Enable the Module Controls menu
            apiKey: "",         // Optional, See API/README.md for details
        }
    },
    

    as @bhepler has added, there are ways to check out the config…



  • here is my config file. I don’t understand markdown feature. might not work with FireFox
    *

    */

    var config = {
    address: “0.0.0.0”, // Address to listen on, can be:
    // - “localhost”, “127.0.0.1”, “::1” to listen on loopback interface
    // - another specific IPv4/6 to listen on a specific interface
    // - “”, “0.0.0.0”, “::” to listen on any interface
    // Default, when address config is left out, is “localhost”
    port: 8080,
    ipWhitelist: [], // Set [] to allow all IP addresses
    // or add a specific IPv4 of 192.168.1.5 :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.1.5”],
    // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.3.0/28”],

    language: "en",
    timeFormat: 24,
    units: "metric",
    
    modules: [
    	{
    		module: "alert",
    	},
    	{
    		module: "updatenotification",
    		position: "top_bar"
    	},
    	{
    		module: "clock",
    		position: "top_left"
    	},
    	{
    		module: "calendar",
    		header: "US Holidays",
    		position: "top_left",
    		config: {
    			calendars: [
    				{
    					symbol: "calendar-check",
    					url: "webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics"
    				}
    			]
    		}
    	},
    	{
    		module: "compliments",
    		position: "lower_third"
    	},
    	{
    		module: "currentweather",
    		position: "top_right",
    		config: {
    			location: "New York",
    			locationID: "",  //ID from http://bulk.openweathermap.org/sample/; unzip the gz file and find your city
    			appid: "YOUR_OPENWEATHER_API_KEY"
    		}
    	},
    	{
    		module: "weatherforecast",
    		position: "top_right",
    		header: "Weather Forecast",
    		config: {
    			location: "New York",
    			locationID: "5128581",  //ID from https://openweathermap.org/city
    			appid: "YOUR_OPENWEATHER_API_KEY"
    		}
    	},
    	{
    		module: "newsfeed",
    		position: "bottom_bar",
    		config: {
    			feeds: [
    				{
    					title: "New York Times",
    					url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    				}
    			],
    			showSourceTitle: true,
    			showPublishDate: true
    		}
    		{
    			module: 'MMM-Remote-Control'
    			// uncomment the following line to show the URL of the remote control on the mirror
    			// , position: 'bottom_left'
    			// you can hide this module afterwards from the remote control itself
    			config: {
        		customCommand: {},  // Optional, See "Using Custom Commands" below
        		customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
        		showModuleApiMenu: true, // Optional, Enable the Module Controls menu
        		apiKey: "",         // Optional, See API/README.md for details
    			}
    		},
    	},
    ]
    

    };

    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {module.exports = config;}


  • Module Developer

    @jiminsav said in Please create a config file:

    module: 'MMM-Remote-Control'

    missing comma after this line

    should be:
    module: 'MMM-Remote-Control',



  • Folks. i figured it out. just commented out everything except the module name and it works. and i did add the comma. thanks