MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Mirroring via Browser (non-zero)?



  • My MM is working great, lots of modules, no issues.

    I was under the impression that I could also access MM via a browser on the LAN, but that isn’t working. I would like to be able to do some testing during train portion of my commute, when I VPN in.

    I’ve tweaked config.js to allow local access, both trying “” and “0.0.0.0”. Neither shows MM in the browser when I go to http://x.x.x.x:8080, as specified.

    Am I trying to do something that won’t work? Do I need to tell pm2 to restart in server mode or something? Thanks in advance for any help.

    var config = {
            address: "0.0.0.0",
            port: 8080,
            ipWhitelist: [],
            language: "en",
            timeFormat: 12,
            units: "imperial",
    
    
    


  • @tc60045 it should… does for me…

    my config start

    var config = {
      address: "", // Address to listen on, can be:
                            // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
                            // - another specific IPv4/6 to listen on a specific interface
                            // - "", "0.0.0.0", "::" to listen on any interface
                            // Default, when address config is left out, is "localhost"
      port: 8086,
      ipWhitelist: [], // Set [] to allow all IP addresses
                                                             // or add a specific IPv4 of 192.168.1.5 :
                                                             // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
                                                             // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
                                                             // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
      language:  "en", //"nb",
      timeFormat: 12,
      units: "imperial",
    
    

    then I go to

    http://192.168.2.26:8086
    

    and the same page as on my actual mirror appears on my pc browser…
    note that my port number is different than after install, as I have other apps consuming 8080-8085

    where are u hosting the mirror? windows? its firewall is VERY restrictive

    oh, vpn… many times the vpn interface is NOT running when MM starts, so, it isn’t listening for connections there. there may be a vpn server setting to enable this


  • Project Sponsor

    I would try putting the IP address of your Raspberry Pi in to the address field. I’m not entirely sure what effect is has on the Magic Mirror process, since the web server should listen on a port as opposed to a particular IP. I do know that I’ve had success with putting the IP address there and accessing my mirrors via web browser. You can find your Pi’s IP address by typing ip address at the command prompt on the Pi. Assuming that you’re using the WiFi connection to connect to your network, look for the entry wlan0.

    If that still doesn’t work, I have some further troubleshooting ideas for you. For starters, try viewing your mirror’s interface while you’re at home. Grab your laptop and point its browser at your mirror’s IP address & port. If that works, then at least you know the Pi is serving up pages to you. Try disconnecting from your home network, firing up your VPN with a shared cellular connection (or any other connection that is not your home network) and try it again.

    Restarting in server mode will only prevent the Magic Mirror interface from using electron to display the mirror via the HDMI jack on the Pi. The Magic Mirror framework is essentially a hosted website. Electron is used to display that website on the local display.

    However: Any changes you make to the config.js file will require you to restart the Magic Mirror process for the changes to take effect.


Log in to reply