MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

new script for screensaver disable



  • the install script processing for screen saver disable isn’t working anymore, and we have a lot more platforms where users need help…

    I have updated my install script to include a new approach…, supports mac too

    but I want to test it out… so I have made a standlone script with just that part of the processing…
    once tested I will include this in the submission to update the install script

    give it a try and let me know

    it will create a little logfile (screensaver.log) in the users home folder

    bash -c "$(curl -sL  https://www.dropbox.com/s/ah7wtk30101xx4t/test_screensaver.sh?dl=0)"
    

    thanks


  • Project Sponsor Module Developer

    @sdetweil

    You are so freakin awesome. Here is the output from my new/current dev machine. Ubuntu 18.04.3 LTS and MM 2.8.0. As your script so accurately put it, Ubuntu DOES have a built in screensaver which can be configured/disabled manually. I thought you might want the information from this test. My thanks to you, Sam, again and again. 👍

    pop@E8300:~$ bash -c "$(curl -sL  https://www.dropbox.com/s/ah7wtk30101xx4t/test_screensaver.sh?dl=0)"
    some other screensaver gsd-screensaver
    please configure it manually
    pop@E8300:~$
    

    screensaver.log confirms terminal output



  • @Mykle1 i think the gsettings command will allow scripted configuration… I sent u a command to test…

    my 18.04 does not have gsd-screensaver running



  • Hello,
    I ran this script a a fresh install of “Raspbian Buster with desktop, July 2019” on a Raspberry Pi 3 B. I got this output:

    pi@magicmirror:~ $ bash -c "$(curl -sL  https://www.dropbox.com/s/ah7wtk30101xx4t/test_screensaver.sh?dl=0)"
    some other screensaver bash
    please configure it manually
    

    I guess the latest Raspian shall be support. Fell free to ask me for some additional information or traces from my setup.
    Regards Dirk

    Edit:
    Currently trying out this manual method: https://www.raspberrypi.org/forums/viewtopic.php?t=249837&p=1525721



  • @mieserwicht can u try again

    i fixed the search filter to exclude the script itself

    thanks



  • @mieserwicht i hope you can try the test script again… see if I corrected the problem…


  • Project Sponsor Module Developer

    @sdetweil said in new script for screensaver disable:

    i hope you can try the test script again… see if I corrected the problem…

    I’m just reporting that your script works for me. Ubuntu 18.04.3 and MM 2.8.0.

    I’d also like to thank you again for all the help you’ve given me and all the scripts you’ve made available to everyone, not to mention all the tech support you give to everyone.

    Voter for Sam! 🙂



  • @Mykle1 thanks. But not looking for a pat on the back.

    I cannot create modules like you do. I love what you produce, I just don’t have that eye.

    But I love the technical support challenge. Learning all these modules. Looking at the code, thinking of fixes.


  • Project Sponsor Module Developer

    @sdetweil said in new script for screensaver disable:

    not looking for a pat on the back.

    Yes, this is part of the reason I wanted to express my gratitude. I see the time and effort that you put in to help others. It is commendable. 👍

    Ahh, thank you for your kind words. I do appreciate that. I’ve had so much fun learning code and creating things. There are a few people here that were kind enough and patient enough to help me. You are not least among them.

    Case in point.

    0_1567390896912_crop.png



  • @sdetweil
    I tried again. The script ran without any console output.
    As result the config:

    @xset s noblank 
    @xset s off 
    @xset -dpms
    

    was now doubled (first I added by hand, second from your script) in the file /etc/xdg/lxsession/LXDE-pi/autostart


Log in to reply