MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Error when trying to run MMM-AssistantMk2



  • [AMK2] assistant ready
    /home/pi/MagicMirror/node_modules/electron/dist/electron js/electron.js: symbol lookup error: /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/node/extension_binary/electron-v3.0-linux-arm-glibc/grpc_node.node: undefined symbol: __atomic_store_8
    npm ERR! code ELIFECYCLE
    npm ERR! syscall spawn
    npm ERR! file sh
    npm ERR! errno ENOENT
    npm ERR! magicmirror@2.9.0 start: `sh run-start.sh`
    npm ERR! spawn ENOENT
    npm ERR! 
    npm ERR! Failed at the magicmirror@2.9.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-10-24T05_25_04_096Z-debug.log
    

    I am trying to install mmm-hotword, MMM-AssistantMk2 to make Magic Mirror today, but I am having an error. What’s the cause?



  • @INMD1 you need to follow the rest of the installation steps, which cover errors like this,



  • @sdetweil I have followed all the steps in the installation guide and still getting the same error as @INMD1 please let me know if there is a certain set of instructions that needs to be followed. Thank you



  • @waseemghaly @INMD1 we will neeed to wait for @Sean to help, he is the module author


  • Module Developer

    Well. I’m not sure because, someone still has this issue despite my instruction in github. But I tested and got success today. So I hope this working for you.

    Reason

    • grpc(which is an essential program to use Google Assistant SDK) installed by npm install in the shell is not compatible with electron of MagicMirror on runtime. Because electron has its own JS engine and it is different with your global level environments. That is why rebuild of grpc for electron is needed.
    • Unfortunately, some last newgrpc versions might have some bug on rebuilding for specific electron. As far as I know, grpc@1.24.0 has one, and grpc@1.24.1 has also (grpc team says it was fixed, but I found another bug on 1.24.1)

    Solution
    In Raspbian Buster / RPI 4B+ I’ve tested.

    1. Check your gcc version. If > = 8, downgrade it to 7.
    sudo apt-get install gcc-7
    gcc -v
    

    It should say gcc version 7.3.0 (Raspbian 7.30-19) or something similar ( < = 7 )
    If not done well, google it how to downgrade your gcc.

    1. then do this; (I’ll assume you’ve already tried npm install on your previous installation step)
    cd ~/MagicMirror/modules/MMM-AssistantMk2
    npm install grpc@1.23.4
    npm install --save-dev electron-rebuild
    ./node_modules/.bin/electron-rebuild
    

    It will take 30 minutes ~ 1 hour. Don’t power off or stop it.

    If not done well… Sorry, I cannot help.
    At this moment, this is one and only way to work properly.
    In my RPI4B+(Raspbian) / Mac (Catalina) / Jetson Nano (Ubuntu 18.04) / Khadas Edge-V (Armbian Buster) / Asus Tinkerboard (TinkerOS), worked today.




Log in to reply