no helper modules



  • Hi @all,

    after new installaton i have no helper modules?
    But MM works fine.
    Is that correct?

    pi@raspberrypi:~/MagicMirror $ npm start

    magicmirror@2.0.0 start /home/pi/MagicMirror
    electron js/electron.js

    Loading config …
    Loading module helpers …
    No helper found for module: alert.
    No helper found for module: clock.
    Initializing new module helper …
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper …
    All module helpers loaded.
    Starting server op port 8080 …
    Server started …
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started …
    Launching application.
    Create new calendar fetcher for url: http://calendar.google.com/calendar/ical/de.german%23holiday%40group.v.calendar.google.com/public/basic.ics - Interval: 300000
    Create new news fetcher for url: http://www.tagesschau.de/xml/rss2 - Interval: 300000

    Joe


  • Moderator

    That’s correct, these modules don’t have any helper module. If you take a look at the module folders you will see there is no node_helper.js file for these modules.
    So all is fine.



  • OK, Thx for info. I am Newbee…



  • Hi,
    I am trying to run it in ubuntu 16 , And I can only see black screen, No module is loading.
    What could be the cause. After that I tried with https://github.com/HackerHouseYT/AI-Smart-Mirror and this module is working fine.

    Any clue?

    Thanks



  • @swagatbiswal said in no helper modules:

    I am trying to run it in ubuntu 16

    I have MM installed on uBuntu. I remember updating node.js and npm was necessary. Are you getting any errors in the terminal or the console of dev tools?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.