MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Black screen instead of desktop after installing PIR sensor



  • Hi, MM Community,
    I recently installed an Adafruit PIR sensor, and configured it using this MagicMirrorCentral guide (https://www.magicmirrorcentral.com/pir-sensor-raspberry-pi-magic-mirror/), and I rebooted like the instructions said. Instead of my normal desktop showing up, all I get is a black screen with my cursor on it, but there is nothing to click. I can’t even get to the terminal to run any commands. Please help me with this, what have I done wrong, and how can I fix it?


  • Project Sponsor

    @09succotash Seems like you use @cowboysdude scripts to control the display.
    Those are really simple scripts which work usually out of the box.

    What I’d guess is that the autostart folder might cause the trouble.
    Which Raspbian ver sion do you use?
    In Raspbian 9 (Jessie) the autostart folder was in

    /home/user/.config/lxsession/LXDE-pi/autostart
    

    (just as written in the above mentioned instructions)

    In Raspbian 10 (Buster) the autostart folder has changed to

    /etc/xdg/lxsession/LXDE-pi/autostart
    

    If you are on Buster, remove the /autostart folder in /home/user/.config/lxsession/LXDE-pi you may have created. Then go to

    /etc/xdg/lxsession/LXDE-pi/
    

    and insert there the the required line in the autostart file

    @/usr/bin/python /home/pi/pir.py
    

    Hope this helps.



  • @Fozi Sorry I didn’t state this earlier…
    I’m using a Raspberry Pi 3 Model B, running Raspbian Stretch.



  • @Fozi How can I undo all of the PIR sensor setup? I want to completely remove it, so I can get my desktop back.


  • Project Sponsor

    @09succotash

    If you cant open a terminal directly on you Pi, then try to open a ssh session from another PC. Then you have terminal access and you can start removing the PIR installation. E.g. open a terminal from a windows PC and enter at the prompt:

    ssh pi@192.168.0.xx
    

    (means the IP of your Pi)

    You’ll be prompted to accept the ssh-key (yes) and then you are prompted to enter the password (keystroke will nor be displayed). Then you should be in.
    As you are using Stretch go edit /home/user/.config/lxsession/LXDE-pi/autostart and remove the ‘@/usr/bin/python /home/pi/pir.py’ entry you made before. save the file and reboot.
    Then go into your pi’s home folder end remove pir.py, monitor_on.sh and monitor_off.sh.
    Basically you do the reverse order when you installed the scripts.



  • @Fozi Ok, I think the SSH interface is disabled. I’ve figured out a way to get into a terminal. It seems that the desktop is there, just its not showing. I was able to right-click, and click Terminal Emulator in the menu. Ok, i’m gonna try this, and see if it works. Thank you.



  • @Fozi It didn’t work, my desktop is still just a black screen. What can I do now to get the Raspberry Pi desktop and taskbar back? All the scripts you told me to remove are gone.


  • Project Sponsor

    @09succotash Umpf…the last thing that comes to my mind…disconnect the PIR-Sensor from GPIO. Maybe it is not connected to the right pins, which may cause that strange behaviour.

    Do you have the MM-software installed? If so, then copy the whole MagicMirror directory to a save place and reinstall Raspbian from scratch. It’s probably the fastest and easiest solution after all, if nothing else is installed on the RPi.

    Maybe someone else here in the forum can help? Guys?



  • @Fozi MagicMirror framework is installed, yes.



  • @Fozi I can’t reinstall Raspbian because this is for a science fair project, due in two weeks, and I put too much work into it for me to be able to finish on time if I reinstall. There has to be a way to get my desktop back without reinstalling.


Log in to reply