MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Problem with updating to 2.10.0 from 2.9.0 using update script



  • Hi,

    so I’m quitte fresh user and I installed 2.9.0 version just few days ago, started doing some config edits and suddenly I got update info on my mirror today, cool

    So I went to https://github.com/MichMich/MagicMirror/blob/master/README.md#updating for update steps, done first (dry/test run) and failed on actual update which resulted with

    error: The following untracked working tree files would be overwritten by merge: installers/dumpactivemodules.js Please move or remove them before you merge. Aborting Updating 500147e..b595cdd you should examine and resolve them

    Well, I’ve done full backup of my directory so I assumed that I can risk deletion of installers/dumpactivemodules.js, so I did

    rm ~/MagicMirror/installers/dumpactivemodules.js

    and run update script again

    bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/upgrade-script.sh)" apply

    but it resulted with the same error The following untracked working tree files would be overwritten by merge: installers/dumpactivemodules.js

    So obviously something is wrong with update script as far as I can tell, I changed almost nothing in my MM, only config + I started doing some custom CSS so nothing out of ordinary IMO



  • yeh, a bug got thru … i have a temporary updated script

    see here.
    https://forum.magicmirror.builders/topic/10859/new-update-upgrade-script-ready-for-testing

    also posted after Mich’s topic of the version update yesterday…
    https://forum.magicmirror.builders/topic/11899/v2-10-0



  • Unluckily scripts under 1st post

    https://forum.magicmirror.builders/topic/10859/new-update-upgrade-script-ready-for-testing/1

    have the same issue at the ones I already tried, I’m not sure if I should go through whole thread, I admit I didn’t



  • @outlying show me the log file, ~/MagicMirror/installers/upgrade.log



  • @sdetweil u need to erase the ~/MagicMirror/installers/dumpactivemodules.js file…

    then run the updated script.

    sorry, forgot that



  • Oh, my bad, I just deleted file rm ~/MagicMirror/installers/dumpactivemodules.js

    and I did run update script, with result

    the log will be /home/pi/MagicMirror/installers/upgrade.log
    No LSB modules are available.
    doing test run = false
    update log will be in /home/pi/MagicMirror/installers/upgrade.log
    
    saving custom.css
    upgrading from version 2.9.0 to 2.10.0
    fetching latest revisions
    updating MagicMirror runtime, please wait
    apply: line 244: npm: command not found
    no modules found needing npm refresh
    restoring custom.css
    

    So I restarted pm2 restart mm but now MM is in error, according to pm2 status


    Running standard pm2 start mm.sh does not start MM anymore, it just go to errored status



  • @outlying but npm had to be installed before… I just use it

    that line 244 is npm install

    and I don’t know where the 'apply: ’ came from



  • this is what my MM/installers/upgrade.log says

    Upgrade started - Thu Jan  2 06:29:19 CST 2020
    system is Linux raspberrypi4 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l GNU/Linux
    the os is Distributor ID: Raspbian Description: Raspbian GNU/Linux 10 (buster) Release: 10 Codename: buster
    user requested to apply changes
    doing test run = false
    
    saving custom.css
    remote name = origin
    upgrading from version 2.9.0 to 2.10.0
    fetching latest revisions
    git fetch rc=0
    current branch = master
    On branch master
    Your branch is behind 'origin/master' by 2832 commits, and can be fast-forwarded.
      (use "git pull" to update your local branch)
    
    Changes to be committed:
      (use "git reset HEAD ..." to unstage)
    
    	deleted:    css/custom.css
    
    Changes not staged for commit:
      (use "git add ..." to update what will be committed)
      (use "git checkout -- ..." to discard changes in working directory)
    
    	modified:   package-lock.json
    	modified:   package.json
    
    Untracked files:
      (use "git add ..." to include in what will be committed)
    
    	0
    	css/save_custom.css
    	somefile
    
    there are 2 local files that are different than the master repo
    
       package-lock.json
       package.json
    
    save/restore files selection = n
    restoring package-lock.json from repo
    restoring package.json from repo
    test merge result rc='' , if empty, no conflicts
    executing merge, apply specified
    merge result rc= 0
     Updating 500147e..b595cdd Fast-forward  .gitignore                                         
        6 -  .snyk                                              
       14 -  .travis.yml                                        
        8 +-  CHANGELOG.md                                       
       28 +-  README.md                                          
       17 +-  config/config.js.sample                            
        7 +-  css/custom.css                                     
       14 -  installers/dumpactivemodules.js                    
       15 +  installers/fixuppm2.sh                             
      183 +  installers/raspberry.sh                            
      560 ++-  installers/screensaveroff.sh                       
      101 +  installers/upgrade-script.sh                       
      361 ++  js/app.js                                          
        6 +  js/main.js                                         
       17 +-  .../node_helper/index.js => js/node_helper.js      
        2 +-  js/server.js                                       
        2 +-  modules/default/calendar/calendar.js               
        1 +  modules/default/calendar/calendarfetcher.js        
        7 +-  modules/default/calendar/debug.js                  
        4 +-  modules/default/compliments/compliments.js         
       39 +-  modules/default/weatherforecast/weatherforecast.js 
        4 +-  package-lock.json                                  
     4187 +++++++++++---------  package.json                                       
       17 +-  run-start.sh                                       
       64 +-  tests/e2e/modules/weather_spec.js                  
      138 +-  tests/e2e/vendor_spec.js                           
        5 +-  untrack-css.sh                                     
        2 +-  vendor/package-lock.json                           
        2 +-  28 files changed, 3648 insertions(+), 2163 deletions(-)  delete mode 100644 .snyk  delete mode 100644 css/custom.css  
    create mode 100644 installers/dumpactivemodules.js  
    create mode 100755 installers/fixuppm2.sh  
    mode change 100644 => 100755 installers/raspberry.sh  
    create mode 100755 installers/screensaveroff.sh  
    create mode 100755 installers/upgrade-script.sh  rename modules/node_modules/node_helper/index.js => js/node_helper.js (98%)  
    mode change 100644 => 100755 run-start.sh
    processor architecture is armv7l
    updating MagicMirror runtime, please wait
    


  • @sdetweil I don’t know how to respond in that case, ofc I have to had it installed earlier in order for MM to work, but right now it seems system is not seeing it, only bash: npm: command not found sooooo … I think since it’s fresh install I will reinstall everything



  • @outlying close that terminal window and reopen it, npm should not have been removed…


Log in to reply