MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM Remote Control Error



  • Hi, I followed the “https://github.com/Jopyth/MMM-Remote-Control” guide and after the first reboot, I get an error that says: Please create a config file. I’m still a noob to linux, and would appreciate some help!
    I have been using putty to make the command input easier.



  • @Chynovsky You probably made a mistake when inserting the module into config.js. Sometimes it is only one character, which is missing or too much. Post your config.js here.



  • [0_1578708666463_config.txt](Uploading 100%)

    Thanks for the response! I didn’t know how to transfer the entire file, so I just copied from VNC into a text document. that’s the attached config js file!

    Update. I don’t think it got attached, but here it is. I don’t know how to find the API key for the MMM remote. I also removed the appid on weather.

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information how you can configurate this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "0.0.0.0", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.0.182", "::ffff:192.168.0.171"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "en",
    	timeFormat: 12,
    	units: "imperial",
    	// serverOnly:  true/false/"local" ,
    			     // local for armv6l processors, default 
    			     //   starts serveronly and then starts chrome browser
    			     // false, default for all  NON-armv6l devices
    			     // true, force serveronly mode, because you want to.. no UI on this device
    	
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			header: "Holidays",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check",
    						url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"					}
    				]
    			}
    		},
    		{
    			module: "compliments",
    			position: "middle_center"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "",
    				locationID: "4703384",  //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: ""
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "",
    				locationID: "4703384",  //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: ""
    			}
    		},
    		{
    		  module: "MMM-NowPlayingOnSpotify",
    		  position: "bottom_left",
    
    		  config: {
    		    clientID: "hidden",
    		    clientSecret: "hidden",
    		    accessToken: "hidden"
    		  }
    		},
    		{
    		    module: 'MMM-Remote-Control'
    		    // uncomment the following line to show the URL of the remote control on the mirror
    		    position: 'bottom_left'
    		    // you can hide this module afterwards from the remote control itself
    		    config: {
    			customCommand: {},  // Optional, See "Using Custom Commands" below
    			customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
    			showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    			apiKey: "",         // Optional, See API/README.md for details
    		    }
    		},		
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    

  • Project Sponsor

    @Chynovsky you are missing commas after

    module: 'MMM-Remote-Control'
    And
    position: 'bottom_left'

    It should be

    module: 'MMM-Remote-Control',
    And
    position: 'bottom_left',



  • Thanks for the update. I just added the commas and I’m still getting an error. Is the localhost change to 0.0.0.0 and the ip addresses added correct?



  • ok, the problem WAS on the local host and IP section. it worked after modifying just the commas you mentioned!
    Any tips on fixing the ip address section?

    “(3) For security reasons, the MagicMirror (and therefore the Remote Control) is not reachable externally. To change this, configure address, and ipWhitelist in your config.js (see these lines in the sample config). For example change address to 0.0.0.0 and add two allowed devices with IP-Adresses 192.168.0.42 and 192.168.0.50:”



  • @Chynovsky

    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.0.182”, “::ffff:192.168.0.171”],

    the ipWHiteList controls which external machines can access the mirror

    127.0.0.1 is only the mirror machine

    and then u have two mangled ipV6 addresses
    I would just start with anyone can access
    ipWhitelist: []



  • I keep getting this error now: This device is not allowed to access your mirror.
    Please check your config.js or config.js.sample to change this.

    I do see “http://ip-of-your-mirror:8080/remote.html” though. so definitely progress.



  • excuse the spam. FINALLY works!


  • Module Developer

    FWIW, in the future,

    Open a terminal
    Type cd MagicMirror and press Enter
    Now you’re in the MagicMirror directory
    Type npm run config:check and press Enter
    MagicMirror will now check your config


Log in to reply