MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-AssistantMk2 (v3)



  • This post is deleted!

  • Module Developer

    MMM-AssistantMk2 v3.2.3

    NEW UPDATES

    3.2.3 (30/04/2020)

    • ADD: New ui -> Simple
    • OPT: Optional Build with Snowboy embed
    • ADD: A2DStopCommand for personalize your stop command (Assistant2Display Server)
    • FIX: some logs

    3.2.2 (17/04/2020)

    • FIX: Package.json (google-assistant)

  • Project Sponsor

    @Bugsounet Hi, I installed this module and A2D module and it’s working fine just few small problems:
    1 When I want to use this module with A2D and the answer is coming on the screen all the modules is go hiding and its coming back on the screen after 1 minute. If I use without A2D everything works fine and the modules just go blurred behind of the answer window and come back fast.
    2 it’s try to use that radio recipe but I can’t manage to start any radio station. I don’t know how it’s work. Every time when the assistant understands station name he look on the Internet to find information about that radio station but never want to start listening. I must install something else ?
    Apart of this everything it’s fine and the module it’s brilliant. Thank you for this.


  • Module Developer

    hi @electros

    1. i think you forget MagicMirror configuration part
      Read here
    2. i have prepare a guide for create it
      Read here

    Apart of this everything it’s fine and the module it’s brilliant. Thank you for this.

    thanks 🙂
    but it’s not finish … there is some surprise again … if i have a lot of time 😉


  • Project Sponsor

    @Bugsounet
    Hello again. I tried what you recommended but without much success. First I made the settings for A2D as you recommended and now when I ask something after the assistant answers me an internet window opens with reference to the answer this being a new and very good thing. But when the assistant starts saying the answer, it hides the modules on the screen apart of calendarext. I was talking about this in the post above. I put a short video on youtube.
    https://youtu.be/DOIkuA60tKo
    As for the radio, I tried after that tutorial but without success.
    I tried to use that file “with-radio_fr.js” but when I say “cheriefm” the assistant shows me the website of the radio station “cheriefm” saying “here is what I found on the web” without starting the radio station.
    Thank you.


  • Module Developer

    @electros said in MMM-AssistantMk2 (v3):

    it hides the modules on the screen apart of calendarext

    it’s a know bug of calendarext

    I tried to use that file “with-radio_fr.js” but when I say “cheriefm”

    ah … “cheriefm” is the name of the block (like a landmark)
    the think to say is “mets chérie fm” in the sample.
    you can try to change it for your language with pattern value

    exemple: if you change pattern value to radio test
    if you say : radio test it will reconize the cheriefm command and execute it (send to A2D mp3 link of the radio and img)


  • Project Sponsor

    @Bugsounet said in MMM-AssistantMk2 (v3):

    it’s a know bug of calendarext

    okay but couldn’t remain all the modules on the screen behind the assistant window?

    ah … “cheriefm” is the name of the block (like a landmark)

    the think to say is “mets chérie fm” in the sample.

    you can try to change it for your language with pattern value

    exemple: if you change pattern value to radio test

    if you say : radio test it will reconize the cheriefm command and execute it (send to A2D mp3 link of the radio and img)

    Well I need to practice more with this. for a start I think I should look for another microphone, the assistant doesn’t really understand what I’m saying.
    Do you think a respeaker board with 2 microphones would be better than a USB microphone?



  • @electros said in MMM-AssistantMk2 (v3):

    I think I should look for another microphone, the assistant doesn’t really understand what I’m saying

    One possible solution for mic

    Working on getting a good hardware solution for MMM-AssistantMK2


  • Project Sponsor

    @Serge Thank you for the link i was looking for a solution like that.



  • Hey everyone, I have a problem with the MMM-assistantMk2:
    The Icon is showing on the mirror, when i click on it in VNC it activates,and works. but it doesnt activate by my voice on the mirror.
    any ideas? these are my configs:

    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out or empty, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	useHttps: false, 		// Support HTTPS or not, default "false" will use HTTP
    	httpsPrivateKey: "", 	// HTTPS private key path, only require when useHttps is true
    	httpsCertificate: "", 	// HTTPS Certificate path, only require when useHttps is true
    
    	language: "en",
    	timeFormat: 24,
    	units: "metric",
    	// serverOnly:  true/false/"local" ,
    			     // local for armv6l processors, default
    			     //   starts serveronly and then starts chrome browser
    			     // false, default for all  NON-armv6l devices
    			     // true, force serveronly mode, because you want to.. no UI on this device
    
    	modules: [
    
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			header: "US Holidays",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check",
    						url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"					}
    				]
    			}
    		},
    		{
    			module: "compliments",
    			position: "lower_third"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "New York",
    				locationID: "", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "YOUR_OPENWEATHER_API_KEY"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "New York",
    				locationID: "5128581", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "YOUR_OPENWEATHER_API_KEY"
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "New York Times",
    						url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    				broadcastNewsFeeds: true,
    				broadcastNewsUpdates: true
    			}
    		},{
      module: "MMM-AssistantMk2",
      position: "top_left",
      config: {
        debug: false,
        ui: "Classic", // Classic2, Classic or Simple
        // if you want Google Nest ui style
        // set Fullscreen ui AND fullscreen_above position
        assistantConfig: {
          projectId: "", // Required to use gaction.
          modelId: "", // (OPTIONAL for gaction)
          instanceId: "", // (OPTIONAL for gaction)
          latitude: 52.0955919,
          longitude: 4.4711253,
        },
        responseConfig: {
          useHTML5: true, // sound render by HTML5
          useScreenOutput: true,
          useAudioOutput: true,
          useChime: true,
          timer: 5000,
          myMagicWord: true,
          //Your prefer sound play program.
          //By example, if you are running this on OSX, `afplay` could be available.
          //by default mpg321 play program is enabled
          //if audio output cutting try with mpg123 or cvlc program
          playProgram: "mpg321",
          chime: {
            beep: "beep.mp3",
            error: "error.mp3",
            continue: "continue.mp3",
            open: "Google_beep_open.mp3",
            close: "Google_beep_close.mp3",
          },
          // false - animated icons, 'standby' - static icons only for standby state, true - all static icons
          useStaticIcons: false
        },
        micConfig: { // put there configuration generated by auto-installer
          recorder: "arecord",
          device: "plughw:1",
        },
        customActionConfig: {
          autoMakeAction: false,
          autoUpdateAction: false, // in RPI, gaction CLI might have some trouble.(current version should be 2.2.4, but for linux-arm, Google haven't updated) so leave this as false in RPI. I don't know it is solved or not.
          actionLocale: "en-US", // At this moment, multi-languages are not supported, sorry. Someday I'll work.
        },
        recipes: [ "with-MMM-TelegramBot.js" ],
        profiles: {
          "default": {
            profileFile: "default.json",
            lang: "en-US"
          }
        },
        useA2D: false,
        A2DStopCommand: "stop",
        useSnowboy: true,
        snowboy: {
          audioGain: 2.0,
          Frontend: true,
          Model: "jarvis",
          Sensitivity: null
        },
      },
    },
    
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    
    

    (it’s running on raspberry pi 4b)


Log in to reply