MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

RPi 3B+ / high %CPU / high temp



  • Hello Everyone,
    I am quite new user here and I would like to ask you for some advise. I have some problems with %CPU and temperature (70-75C)
    Platform: RPi 3B+
    Electron: v3.1.13
    MM: v2.10.1
    Cooling: only Al heat sink (no fan)

    Please find below nmon screenshots:

    Do you have any ideas how can I solve my problem. I checked previous discussions but information there is quite old:
    link text

    I hope you have some solutions for those problems;)



  • ![CPU](proc)
    ![Proc](memo)



  • @Ebson what does it look like without MM started?



  • MM-stop)
    I guess too many 3rd party modules ;/ I will try to look for the one that causes problems.



  • Please discard my previous post. Here is some more detailed testing:
    final

    It looks like ‘Weather or Not’ and ‘DarkSky’ forecast cause some problems. I will try to play with update interval.

    Anyway, like in here: old discussion, my %CPU with default modules look a bit higher than the one presented in old post.

    Do you think that electron version has some influence?
    Could someone else present own %CPU with default modules?


  • Project Sponsor Module Developer

    @Ebson said in RPi 3B+ / high %CPU / high temp:

    'Weather or Not’

    CPU usage and heat have arisen now and again. If you search the forum you’ll find lots to read and perhaps a solution. At times it has been the version of Pi and other times the version of electron.

    Concerning MMM-WeatherOrNot: There are only 2 things that I can think of that might affect your Pi negatively.

    1. An extremely low updateInternal. The default is updateInterval: 10 * 60 * 1000, (10 minutes)

    2. The use of the animated icons option.

    I would like to hear from others if they are having the same issue, whether with a low updateInterval or the animated icons.



  • I used:

    • Weather or Not:
      updateInterval: 60 * 60 * 1000,
      icons: Climacons (no animation)
    • DarkSky:
      useAnimatedIcons: false,
      animateMainIconOnly: false,
      updateInterval: 60,
      requestDelay: 1000,
      updateFadeSpeed: 2000
    • 2x Newsfeed:
      reloadInterval: 10*60*1000,
      updateInterval: 15000,
      animationSpeed: 0

    and I ended up with:
    finnnnnnn
    I still need to consider adding fan but increasing intervals and turning off animation helped a lot
    Maybe I will play also with some older electrons.

    Thank you for your reply;)


  • Project Sponsor Module Developer

    @Ebson

    Honestly, I don’t think a 60 minute updateInterval is necessary for WeatherOrNot.

    DarkSky updateInterval is 60 ms??? (I don’t use that module). If that is miiliseconds it would certainly cause trouble.



  • You are right. I will change it into 6h… or even longer.
    There is written in DarkSky’s Documentation that the value should be given in minutes. I don’t really know how to check whether it is not a mistake in Doc. I will make some testing;)



  • DarkSky:

      setInterval(function() {
        self.getData();
      }, self.config.updateInterval * 60 * 1000); //convert to milliseconds
    

    So, value should be given in minutes in config file. Anyway, I will increase a value. BTW, it is also nice module for weather.


Log in to reply