MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-MyCommute not showing up today.



  • Hi everyone,

    I’ve been working on my MagicMirror for a while now, and installed MMM-MyCommute a while back along with MMM-GoogleMapsTraffic at about the same time. Today I booted up my Magic Mirror to find that the MyCommute module did not show up, and there was an update notification at the top. I updated MyCommute, applied the new changes to the config, and still, nothing showed up when I ran Magic Mirror again. I tried running it with the exact example config shown in the readme with my API key from google, and still nothing. It was running fine before today. Does anyone have any ideas?

    Note - MMM-GoogleMapsTraffic is still working well, and when I ran npm start dev I found that there was a potential error with using the same API keys for both modules (which I thought was weird since It’s been running fine this whole time), so I made a brand new API key, but still nothing.

    Thanks so much for the help!



  • @gwiz said in MMM-MyCommute not showing up today.:

    MMM-GoogleMapsTraffic
    there was a bug in this module, I provided a fix for the developer, but they have not incorporated it yet
    it caused interference with other modules

    u can try my version
    rename the modules/MMM-GoogleMapsTraffic folder out of the way
    cd ~/magicMirror/modules
    git clone https://github.com/sdetweil/MMM-GoogleMapsTraffic

    then restart your mirror



  • That worked perfectly! Thanks so much!



  • Hi @sdetweil,

    I’m having the same exact problem again, do you think it could be interfering with MMM-GoogleMapsTraffic again? I have no updates to install, and MMM-MyCommute keeps shutting off.

    Thanks



  • @gwiz i have no idea… if you open the developers window (ctrl-shift-i or F12 on the keyboard),
    and select the console tab, and put commu in the filter field, do you see any errors?



  • It says suspended but I’m not sure why, how can I check the reason?



  • @gwiz do you use pages, or some activity monitor? pir, or somesuch

    sadly there is no notification for the call to suspend on WHO, but now that you found that line,
    you can re-enable other messages (remove filter) and then find the suspend again (search works)
    and find if some module said something just before



  • Here is what it shows me:

    Screen Shot 2020-05-09 at 7.30.05 PM.jpg

    Not sure if what you asked, but I do use VNC Viewer to connect and edit the mirror without taking the frame off. Could that have something to do with it?

    Thanks for your help



  • @gwiz said in MMM-MyCommute not showing up today.:

    but I do use VNC Viewer to connect and edit the mirror

    shouldn’t have anything to do with it… I edit thru an ssh connection all the time. never touch the mirror itself

    looking at the code it hides itself if its outside the configured times or there are no destinations…

    there are 4 different ones, which are u using?

    git remote -v in the module folder will tell you



  • Sorry I’m not sure what you mean, I ran the command and this is what it gave me:

    Screen Shot 2020-05-09 at 8.01.07 PM.jpg


Log in to reply