MMM-Traffic does not work after latest update ??



  • After the newest update the module does not work anymore, everything is in Config.JS and I have installed the update, but after that the module is not on the magic mirror, everthing else is there from the others modules :

    {
        module: 'MMM-Traffic',
        position: 'top_left',
        classes: 'dimmed medium', //optional, default is 'bright medium', only applies to commute info not route_name
        config: {
            api_key: 'XXXX',
            mode: 'driving',
            origin: 'XXXX',
            destination: 'XXXXX',
            arrival_time: '0800', //optional, but needs to be in 24 hour time if used.
            route_name: 'XXXX',
            changeColor: true,
            showGreen: true,
            limitYellow: 5, //Greater than 5% of journey time due to traffic
            limitRed: 20, //Greater than 20% of journey time due to traffic
            traffic_model: 'optimistic',
            interval: 120000, //2 minutes
    	showWeekend: true,
    	allTime: true       
        }
    },
    


  • I guess some error occurs within the module. So, it might be helpful to start the mirror with console (npm start dev) and post the related, occurring errors (all errors should be related else you got more problems :D) here.



  • @Anhalter42 said in MMM-Traffic does not work after latest update ??:

    npm start dev

    I ca see there is a error > MMM-Traffic.js:36 Uncaught SyntaxError: Invalid or unexpected token / how can I see where the error is in MMMTraffic.js is



  • @ironman_DK Ahhh I got it, there was missing a ’ in a line, thank you for your help



  • @ironman_DK said in MMM-Traffic does not work after latest update ??:

    how can I see where the error is in MMMTraffic.js is

    First of all, I’m glad you was able to solve the problem yourself :thumbsup:

    For the future, the line in which the error occurs is printed to the console. “MMM-Traffic.js:36” means you have to check the line 36 in file MMM-Traffic.js.



  • @ironman_DK did you modify the files before, because on github it looks fine


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.