Lightdm.conf file blank



  • I was still having the blank screen happen after 30 minutes so i went back and checked the autostart and lightdm.conf files to make sure I hadn’t made any mistakes. However, the lightdm.conf file is coming up with no text in it. What is the best way to restore this information so i can make sure the [SeatDefaults] has the correct settings?



  • @RE_Magic_Mirror The best way to keep your mirror running is to install a screensaver and then configure the screensaver to never run. Yeah, it’s a bit weird.

    Install the screensaver program: sudo apt-get install xscreensaver

    Once you do, start your Pi and get to the desktop. If you have already configured your Pi to start the Magic Mirror interface, click ctrl+q to exit. Open the menu by clicking on the Raspberry start button with your mouse, or clicking the special/window key on your keyboard. Go to Preferences and there should be a new entry called “Screen Saver”. Click/Press enter to activate the screen saver configuration.

    On the configuration screen, there is a drop-down box with options as to which screen saver you wish to run. I believe the default is “random screensaver”. Navigate to this drop down box and select “disable screensaver”. Close the screen saver configurations window.

    That’s it. That should keep your Pi from going black.



  • is there any problem with the lightdm.conf file being empty, if not everything else is running smoothly.



  • @RE_Magic_Mirror I don’t think there is a problem, no. I haven’t done any research on the topic, but I believe the lightdm.conf file was deprecated around the time the Wheezy version of the Raspian operating system was released. At least… changes to that file on Wheezy didn’t seem to have the desired effect. That continued on Jessie.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.