Not updating after network lost



  • I have a pi3 powered mirror that works great when first powering up. A few times a day I can see via the ping module that I loose network. I guess that is normal since the pi is behind the frame, using wifi and is placed some distance from the router.

    But after wifi has dropped once, the modules (calendar and MMM-ResRobot) are never updated again. The calendar is stuck in time. Even though network comes back. It seems the ping module is updated though.

    If I restart the mirror, the modules will update. And if I access the mirror remotely (with MMM-RemoteControl) it shows correctly remotely.

    Any ideas what to do?



  • It seems like the browser is crashing or not auto updating since it works when you access from a new location/browser



  • @Lange but the ping module is updated along with the clock module, so a crash seems unlikely. But what can I do to debug this?



  • The Pi may be turning off the wifi to conserve energy. So, you might need to turn off power management. Here’s a good walkthrough courtesy of modmypi (https://www.modmypi.com/blog/disable-wifi-power-management).

    If you are experiencing drop outs on your wifi interent connection, it could be that your dongle is turning itself off after an idle period. To stop your wifi dongle doing this, we need to disable its power management.

    Either SSH to your Pi, or login to its desktop and open up a terminal.

    First, make a backup of your existing interfaces file:

    sudo cp /etc/network/interfaces /etc/network/interfaces.backup

    Now edit the original interfaces file:

    sudo nano /etc/network/interfaces

    Assuming you haven’t edited this file before all you need to do is delete its entire contents, and copy the following into it:

    auto lo

    iface lo inet loopback
    iface eth0 inet dhcp

    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off
    iface default inet dhcp

    The important block of code here is:

    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off
    iface default inet dhcp

    So only add that section if you have a custom configuration for any other network interfaces.

    Now exit the nano editor and save your changes:

    Ctrl+x
    Y
    Enter

    Now reboot your raspberry pi:

    sudo reboot

    Once the raspberry pi has rebooted, check that the wifi dongle’s power management has been disabled by typing this command:

    iwconfig

    And checking for: “Power Management:off”



  • @retroflex I think I have a similar issue, did @rcollie suggestion solved the issue for you ?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.