Translate errors in "NEWS"



  • Hi guys. I just updated my RPI2 from MM1 to the new MM2. Works like a charm!
    But I got one problem. I uses a RSS feed from a swedish newsfeed called “Expressen” and they uses swedish letters like “ÅÄÖ”. This aint a problem overall on the MM2 (Like calenders, weather and so on. There it works) But on the newsfeed i only get “?” symbols.

    I’ve checked and UTC-8 shall work, but I have tried change it anyway to ISO-8859 but no success.
    Anyone that could help me with this problem? Thanks!



  • Hey! I got the same issue, i solved it by using this:

    {
    	module: 'newsfeed',
    	position: 'bottom_center',
    	config: {
    		feeds: [
    			   {
    			   title: "Expressen",
    			   url: "http://expressen.se/rss/nyheter",
    			   encoding: "ISO-8859-1",
    			   },
    		        ],
    			showSourceTitle: true,
    			showPublishDate: true,
    			showDescription: true,
    			reloadInterval: 200000,
    			updateInterval: 15000,
    			animationSpeed: 3500
                      }
    }, 
    

    When i was trying with Aftonbladet, DN and my local paper, they all worked without encoding, so there must be something in Expressens feed.


  • MagicMirror Creator

    Like @Snoevit says: check out the encoding field.



  • @Snoevit I did try it, but I probly made something wrong cause now it’s working. Thanks alot! :)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.