MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

stuck with MMM-RTSP module

  • Re: [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras

    I can’t get this working.
    So i’ll started to do some independent test.
    installed VLC player and then put my camera rtsp stream into VLC.
    Getting this message: vlc can’ t open rtsp://userxxxx:pwxxxxx%@

    next stream in VLC plays perfect

    then I installed OMXplayer
    Loaded following stream:

    //sudo omxplayer -o hdmi rtsp://JSTAL:xxxxx@

    This works fine, full videoscreen of my IPcam.

    then I modified config as follows

    		            module: 'MMM-RTSPStream',
    			    classes: 'default everyone',
    		            position: 'middle_center',
    		            config: {
    		                autoStart: true,
    		                rotateStreams: false,
    		                rotateStreamTimeout: 10,
    		                showSnapWhenPaused: false,
    		                moduleWidth: 354,
    		                moduleHeight: 240,
    				localPlayer: 'omxplayer',
    		                stream1: {
    		                    name: 'Webcam 1 Test Stream',
    		                    url: 'rtsp://JSTAL:xxxxxxxx@',
    		                    snapshotUrl: '',
    		                    snapshotRefresh: 10, // Seconds
    		                    frameRate: "25",
    		                    port: 9999,

    conclusion so far, installed software is OK

    ‘xxxxx’ in the rtsp stream is where i put my password.
    password contains special char ‘%’ - can the be the reason of VLC not showing the stream.

    so i’m stuck…
    any idea’s to solve are welcome.

  • Maybe try changing the % to %25. This is the escape sequence for a percent sign in a url.

  • @Shockwave

    thanks for the tip.
    indeed changing the URL like you mentioned works in VLC. I can see the video image.
    But still didn’t worked on the MM.
    So I adapted the passwords.
    Now all works fine.

  • Guys,
    I was able to install and configure correctly the RTSP module but only one camera works.
    The second stream just show a black video.
    I tried out to open it via OMXPLAYER and I do not get eny error but the video isn’t displayed.
    Any suggestion?

Log in to reply