MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Alexa pi install, mic doenst work?



  • Hello everyone…
    I hope someone of you there can help me with the alexa pi…
    when i start alexa pi by sudo systemctl start AlexaPi.service and than checkinhg the status by sudo systemctl status AlexaPi.service i have got this error…

    pi@raspberrypi:~ $ sudo systemctl status AlexaPi.service
    ● AlexaPi.service - Alexa client for all your devices
    Loaded: loaded (/usr/lib/systemd/system/AlexaPi.service; enabled)
    Active: failed (Result: exit-code) since Fri 2017-10-13 18:22:22 CEST; 1min 14s ago
    Docs: https://github.com/alexa-pi/AlexaPi/wiki
    Process: 1320 ExecStart=/usr/bin/python /opt/AlexaPi/src/main.py --daemon (code=exited, status=1/FAILURE)
    Main PID: 1320 (code=exited, status=1/FAILURE)

    Oct 13 18:22:22 raspberrypi python[1320]: ALSA lib pcm.c:2239:(snd_pcm_open_…e
    Oct 13 18:22:22 raspberrypi python[1320]: ALSA lib pcm.c:2239:(snd_pcm_open_…e
    Oct 13 18:22:22 raspberrypi python[1320]: ALSA lib pcm_dmix.c:1022:(snd_pcm_…e
    Oct 13 18:22:22 raspberrypi python[1320]: connect(2) call to /tmp/jack-999/d…)
    Oct 13 18:22:22 raspberrypi python[1320]: attempt to connect to server failed
    Oct 13 18:22:22 raspberrypi python[1320]: CRITICAL: Your input_device 'plugh…:
    Oct 13 18:22:22 raspberrypi python[1320]: pulse
    Oct 13 18:22:22 raspberrypi python[1320]: default
    Oct 13 18:22:22 raspberrypi systemd[1]: AlexaPi.service: main process exited…E
    Oct 13 18:22:22 raspberrypi systemd[1]: Unit AlexaPi.service entered failed …
    Hint: Some lines were ellipsized, use -l to show in full.

    i think its the sound card but i dont know how to install and configure the sound card…
    i install teamvierwer so mayb someone overthere van help me? 🙂 thnx



  • @Milad222
    Hi,
    I bought USB 3D sound card adapter since my Pi3 hasn’t Mic port and than i connected my jack 3.5 Microphone to it .
    0_1508003228825_98a215cb-a46f-46ef-9eca-0e08d88c4609-image.png

    If you have another USB HD camera with built-ed Mic you have to disable it since it will not work properly with your speech recognition software. I faced recently with this problem. I couldn’t configure it.
    If you have USB HD camera with built-ed Mic please let me know and i show you how to disable it.
    Best,



  • @aro28 said in Alexa pi install, mic doenst work?:

    USB HD camera with built-ed Mic please let

    Hi Thanx for replying me, i have a logitac usb camera with buildin cam… the mic work in the pluseaudi pannel… i see it moving at the input section…

    so i think i have to disable it…? i have also teamviewer installed on my laptop you can connect me if its to difficult to explane… 🙂


  • Module Developer

    @Milad222
    I think it could be related with permission of account.
    As I know, Alexa Pi is running with Deamon mode, it means, the account of Alexa Pi is different with your personal account which you had tested audio with.(maybe pulse audio)
    I have no idea how to solve because I’m not an expert, but most of the cases seem to be related to that point in using Alexa Pi.



  • @aro28 0_1508156189755_Errormelding.PNG

    This is printscreen of my settings and error…


  • Module Developer

    @Milad222
    Can you record and play with these commands? Does it work?

    arecord -d 10 test.wav && aplay test.wav
    


  • @Sean said in Alexa pi install, mic doenst work?:

    arecord -d 10 test.wav && aplay test.wav

    Yes that works…



  • @Milad222 said in Alexa pi install, mic doenst work?:

    @Sean said in Alexa pi install, mic doenst work?:

    arecord -d 10 test.wav && aplay test.wav

    Yes that works…

    pi@raspberrypi:~ $ arecord -d 10 test.wav && aplay test.wav
    Recording WAVE ‘test.wav’ : Unsigned 8 bit, Rate 8000 Hz, Mono
    Playing WAVE ‘test.wav’ : Unsigned 8 bit, Rate 8000 Hz, Mono

    pi@raspberrypi:~ $
    pi@raspberrypi:~ $ aplay test.wav
    Playing WAVE ‘test.wav’ : Unsigned 8 bit, Rate 8000 Hz, Mono
    pi@raspberrypi:~ $


  • Module Developer

    @Milad222
    I’m not an expert, but Only I can say is…

    Anyway, this is not realted with MagicMirror. You’d better get help from AlexaPi develpers or users on gitHub(or wiki)



  • Since i installed 3D sound card(external USB card with speaker and Mic) i disabled other internal HD web camera’s Microphone which came with my Touch Screen monitor. I used usual 3.5 mm jack mic.

    1. Go to- -> sudo nano /lib/modprobe.d/aliases.conf
    ##options snd-pcsp index=-2 - This is my USB Mic which is came with internal HD camera on my monitor.
    options snd-usb-audio index=-2
    options cx88_alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2

    2. Go to --> sudo nano /etc/modprobe.d/raspi-blacklist.conf and added below command
    blacklist snd_bcm2835

    Above “snd_bcm2835” is my internal sound card

    That’s all.