MagicMirror² v2.6.0 is available! For more information about this release, check out this topic.

Failed at the magicmirror@2.2.2 start script ''

  • @cruunnerr
    I won’t be so sure…

    > magicmirror@2.2.2 start /home/pi/MagicMirror
    > sh
      throw new Error('Electron failed to install correctly, please delete node_modules/' + path.basename(__dirname) + ' and try installing again')
    Error: Electron failed to install correctly, please delete node_modules/electron and try installing again
        at Object. (/home/pi/MagicMirror/node_modules/electron/index.js:9:9)
        at Module._compile (module.js:570:32)
        at Object.Module._extensions..js (module.js:579:10)
        at Module.load (module.js:487:32)
        at tryModuleLoad (module.js:446:12)
        at Function.Module._load (module.js:438:3)
        at Module.require (module.js:497:17)
        at require (internal/module.js:20:19)
        at Object. (/home/pi/MagicMirror/node_modules/electron/cli.js:3:16)
        at Module._compile (module.js:570:32)
    npm ERR! Linux 4.9.59-v7+
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "start"
    npm ERR! node v6.12.3
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! magicmirror@2.2.2 start: `sh`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.2.2 start script 'sh'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     sh
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs magicmirror
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log

  • didn’t expect that ^^

    try going to your MagicMirror folder and type npm install electron@1.4.15
    Maybe it will say, that this version is invalid.
    Check the version here: /home/pi/MagicMirror/node_modules/electron/dist/version

    or try it global sudo npm install -g electron@1.4.15

    Question: Did u first install it manually and then with the automatic installer?
    If so, did u delete your MagicMirror folder before using the automatic installer? If not, maybe this causes the error.
    So try deleting the MagicMirror folder and then use the automatic installer again.

  • This post is deleted!

  • @cruunnerr I went to jessie, tried again… it failed… reinstalled electron 3 times… still fails… always the same damn error…
    i think i’m gonna build my own webpage with blackjack and hookers…

    This is so incredible…

  • Hi

    i have the same Problem npm install electron@1.4.15 dasen`t work. it was of no use a blank mirror with the same error log.

    have now one any idea ???

  • @Homerj i’m desperate, 2 days no result… i’d love an img to flash with everything working… anyone?

  • I have restored an old backup with which it ran with version 2.13 since 01:18 I have no chance to get it to work.
    I have a rp3 with stretch on the run where synonymous fhem over it runs. if any one idea would be great

  • @Homerj could you share it?

  • @L_i_v_e
    Ok i checked your earlier posts again.
    U did execute the whole stuff as root user. Thats not necessary and even not good!
    I don’t know what else u did as root, but maybe first try to delete the whole MagicMirror Folder and run the command without sudo.
    bash -c "$(curl -sL"

    Or try a new installation of the raspbian and begin with this (for a full raspbian) or this (for a lite raspbian) tutorial. Do it exactly as its wrote down!

  • @cruunnerr From when sudo is a bad thing? I’ll try now