{HowTo} turn on/off your monitor (Time based, PIR/Button, App)



  • OK everything is working after creating scripts from step 2.2 🙂



  • is there possibility to turn off PIR at specified time ? f.e. from 9pm untill 7am it will be off so if there will be movement display will not turn on.



  • @Maros

    Glad u got it working. 🙂

    So u use the script from point 2.2 ?

    Then u could kill the pir.py at 9pm and start at 7am via cronjob. With that u were able to define each day for itself 🙂

    The command to kill the pir.py script is

    sudo pkill $(ps aux | grep python pir.py | awk '{ print $2 }')
    

    So the easiest way is to just edit your crontab. Try it like this:

    1. nano killpir.sh

    2. Write this into file and save with CTRL+X and Yes

    sudo pkill $(ps aux | grep python pir.py | awk '{ print $2 }')
    
    1. chmod +x killpir.sh

    2. sudo nano /etc/crontab

    3. Write this into file and save with CTRL+X and Yes:

    0 21 * * * /usr/bin/sh /home/pi/killpir.sh
    0 7 * * * /usr/bin/python /home/pi/pir.py
    

    So for example your crontab looks like this:

    # /etc/crontab: system-wide crontab
    # Unlike any other crontab you don't have to run the `crontab'
    # command to install the new version when you edit this file
    # and files in /etc/cron.d. These files also have username fields,
    # that none of the other crontabs do.
    
    SHELL=/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    
    # m h dom mon dow user  command
    17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly
    25 6    * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
    47 6    * * 7   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
    52 6    1 * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )
    0 21    * * *   root    /usr/bin/sh /home/pi/killpir.sh
    0 7     * * *   root    /usr/bin/python /home/pi/pir.py
    #
    

    Didn’t try this solution at all, but hope/think this works 🙂

    I would be glad about a feedback 😉



  • @cruunnerr ok thank you i’ll try it and let you know if it work.

    just one question is it not needed to start pir.py in background ?

    /usr/bin/python /home/pi/pir.py &



  • cron will start the pir.py in background. The scenario will be like:

    Boot up magic mirror = starts pir.py via rc.local
    at 21pm = stops pir.py via cron
    at 7am = starts pir.py via cron

    from this on the circle is closed and cron will repeat this every day (in background)
    well… i think so… maybe i am wrong 😕

    When u reboot the mirror between 21pm and 7am the pir.py will be active for sure until the next 21pm will be reached … 😉

    edit:
    it would also be possible to implement a while-loop in the pir.py script to check if it is between 21pm and 7am.
    But i never worked with that yet -.-

    maybe u can get what u want here or here or here



  • ok i’ve checked and it’s not working fully.
    problem is with /usr/bin/sh /home/pi/killpir.sh

    there is no /usr/bin/sh only rsh

    edit.
    ok i’ve changed path to /bin/sh and now i get error :
    grep: pir.py: No such file or directory
    pkill: no matching criteria specified
    Try `pkill --help’ for more information.

    even if pir.py is running (i can see it in ps -ef |grep pir)

    edit ok i was able to fix it i’ve edited killpir.sh to
    sudo kill $(ps aux | grep python | grep pir.py | awk ‘{ print $2 }’)

    now it will kill process pir.py

    but problem is that even if this script (pir.py) is not running the mirror still turns on when there is movement and turns off after 30s no movement … strange



  • When the pir.py isn’t running, then it isn’t this script which turns on your monitor.
    Do you have the MM-PIR module active?

    Please try to edit your rc.local and delete the autostart of the pir.py to see, if the monitor still turns on/off when there is movement.

    if not, then the pkill command isn’t working, which would confuse me, because i just tried it by myself on my mirror.
    via ssh i just entered the sudo pkill $(ps aux | grep python pir.py | awk '{ print $2 }')" command and my pir wasn’t working.


    and to your first problem, which u solved by yourself…

    u could also try to edit the killpir.py to this:

    #!/bin/bash
    sudo pkill $(ps aux | grep python pir.py | awk '{ print $2 }')
    

    then u should be able to just let your cronjob look like:
    0 21 * * * root /home/pi/killpir.sh



  • Yes i’ve active mmm-pir module.
    I’ll try your solution and let you know
    Thank you 😉



  • i’ve removed line from rc.local and mirror is still working as should (turn on when there is movement and turn off after 30s as set up in MMM-PIR module)



  • Was the MMM-PIR sensor module active while you tried the script of 2.2? You will have to disable the module. Then you create and load the scripts and create the cronjob. If you don’t disable the MMM-PIR module then it will keep waking up the screen even if you disabled the pir.py script.

    Please excuse me if that’s what you did and I just got it wrong.