Modifying Magic Mirror for a gift...



  • I have a couple questions about modifying Magic Mirror to make it user-friendly for someone’s gift who I don’t want to worry about updating, connecting a keyboard and mouse, etc…

    My screen will go blank after about 5 min. It’s not turning off, but all the modules disappear. If I move my mouse or touch my keyboard, they immediately pop back up. Is there a way to prevent this, or make a very simple way to “wake up” the MM without a mouse or keyboard?

    Is there any way to prevent it from displaying the update notices? Once I get everything the way I’d like, I’d prefer there be a way to turn updates off. An alternative would be to install the updates remotely.

    Thank you for the help,
    Tom



  • step 3 of this tutorial https://forum.magicmirror.builders/topic/236/complete-setup-tutorial/6 describes the process for stopping the screen blanking. hopefully that solves that problem for you.

    as for the update notice, are you referring to the display alert in the top bar? you can simply remove the call for that module in your config.js file and then it wont display that header at all.

    this is a snippet of the default contents of config.js

    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    

    you can delete the module call altogether or comment it out with /* */ symbols like so…

    	modules: [
    		{
    			module: "alert",
    		},
    /*		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    */		{
    			module: "clock",
    			position: "top_left"
    		},
    


  • In my opinion the most user friendly way is a PIR sensor ^^
    Or u just install a button :)



  • In my experience, the technique used in the Complete Setup Tutorial no longer works as intended. In order to keep the mirror on all the time, I recommend the following:

    • Install X-Screensaver by entering sudo apt-get install x-screensaver
    • Turn off your MM briefly by clicking Alt-Q. (If you’re using PM2 to maintain the process, enter pm2 stop mm or whatever).
    • Using a mouse, configure X-screensaver to not use a screensaver. I believe you can access the X-screensaver configuration interface by clicking on the Raspberry icon -> Preferences -> Screensaver. The drop-down to select the screensaver mode will have an option for “disable screen saver”.
    • Close the configuration panel and then run your MagicMirror process normally.

    Credit goes to @sgtwtf for this suggestion.



  • I went ahead and did the PIR sensor. After a few frustrating days I got it working- very cool. Thank you for the suggestion. I’ve also commented out the update notifications- thank you for pointing out the setup tutorial, there were a few other things on there I’ve missed.

    Thanks for the help,
    Tom


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.