MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-PIR-Sensor: Everything works fine, just one thing not...



  • My sensor is working fine for months now. It works as designed (shuts my mirror down after 5 minutes and is reactivated if someone enters the room or goes by).

    But i noticed this:
    After a reboot of the whole PI mirror system, the screen isn’ t turned off by the MMM-PIR-Sensor-module (even after waiting for more than an hour or more - i think it would be on forever). Only if someone goes by, the sensor shuts down the screen (monitor) for a millisecond and immediately after that, turns the screen on again. After that, the PIR sensor works fine like every day before…

    Does any one of you ever had a similar behavior of a PIR sensor configuration?

    Thanks!

    Medo


  • Module Developer

    Hi Medo,
    i think i read something that after a reboot you have to wave your hand (for example) in front of sensor once, so the sensor is active.

    AxLED



  • @AxLed
    Thanks, did not know that this has to be done to “activate” a PIR sensor…Interesting…hmm…

    Does anyone know, if there is a method that this can be “simulated” in any way?



  • one idea is to just put the tvservice -o command in your rc.local.
    before that u should do a little sleep.

    like this:

    sudo nano /etc/rc.local

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    # Print the IP address
    _IP=$(hostname -I) || true
    if [ "$_IP" ]; then
      printf "My IP address is %s\n" "$_IP"
    fi
    
    sleep 60 &
    
    tvservice -o
    
    exit 0
    

    So on every reboot it will wait 60 seconds (just to let everything start like MM) and then turn the monitor off.



  • Sounds like a great idea! I will try that soon and will geht you a reply if it works! Thanks for that possible solution…



  • @cruunnerr
    Your solution worked like a charm.
    Thanks!



  • @Medo

    Glad to hear that 🙂