MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

MMM-Domiticz


  • Module Developer

    Description

    Hello MagicMirror users,

    I have made a module to display data from your Domoticz system.

    At this moment it shows the devices that have been switched on. The CO2 levels with a threshold and the level of the battery driven devices.

    In this module you can set your own labels in your preferred langauge

    Screenshots

    0_1522221997050_screendomoticz.png
    More options are coming soon

    Download



  • Awesome…gonna test it out tonight!


  • Module Developer

    Just let me know if you like something added.



  • HI !

    Awesome module so great
    how is possible to adapt it fot my country and my town ?
    please


  • Module Developer

    In your config.js you just add the proper Titles

    energyTitle: ‘Energy used by’ ,
    batteryTitle: ‘Battery level’,
    coTitle: ‘CO2 level’

    these values are by default, so if you don’t give any titles It will be in English

    Domoticz is from your home domotica system.



  • For some reason I can’t get it to work…

    I copy & pasted the example from Github (corrected the Domiticz typo), changed the API details, but it doesn’t work. I suspect this other Domoticz module could have something to do with it…

    MMM-domoticz

    {
                           module: 'MMM-domoticz/domoticz',
                           header: 'Smart Home',
                           position: 'bottom_left',
                           config: {
                           apiBase: "http://192.168.1.12",
                           apiPort: "80",
                           sensors: [
    

    I changed renaming MMM-Domoticz (this module) to MMM-Domoticz2, but then it also would not run. Below is a copy of my config.js entry:

    {
            module: "MMM-Domoticz",
            position: "bottom_left",   // see mirror setting for options
            config: {
                    updateInterval: 45, // every 45 seconds
                    apiBase: '192.168.1.12',
                    apiPort: 80,
                    apiUser: "abcd",
                    apiPw: "efgh",
                    moduleTitle: "Current temperatures Domiticz",
                    energyTitle: "Energy used by",
                    batteryTitle: "Battery level",
                    coTitle: "CO2 level"
                    energyNow: "Currently",
                    energyTotal: "Energy used",
                    batteryThreshold: 20,
                    coThreshold: 650,
                    showItems: ['temperature','energy','battery','co'],   // possible items  temperature, energy
                    excludedDevices: ['none']  // Device that will not be shown
            }
    },
    

  • Module Developer

    @marknlx Thanks for pointing out the typo. It has been fixed at github

    Are you sure your Domoticz is using port 80? Normally it is 8080
    you can try to login to Domtoticz with your browser first.

    Then enter this url http://192.168.1.12:80/json.htm?type=devices&filter=all&used=true&order=Name

    It should give you something like

    {
       "ActTime" : 1522301589,
       "AstrTwilightEnd" : "22:03",
       "AstrTwilightStart" : "05:22",
       "CivTwilightEnd" : "20:39",
       "CivTwilightStart" : "06:45",
       "DayLength" : "12:46",
       "NautTwilightEnd" : "21:20",
       "NautTwilightStart" : "06:05",
       "ServerTime" : "2018-03-29 07:33:09",
       "SunAtSouth" : "13:05",
       "Sunrise" : "07:19",
       "Sunset" : "20:05",
       "result" : [
          {
             "Data" : "Off",
             "Description" : "",
             "Favorite" : 1,
             "LastUpdate" : "2018-03-28 15:06:24",
             "Name" : "Livingroom mainlight",
             "PlanID" : "",
             "PlanIDs" : [ 0 ],
             "Protected" : false,
             "Status" : "Off",
             "Type" : "Group",
             "TypeImg" : "group",
             "UsedByCamera" : false,
             "XOffset" : 0,
             "YOffset" : 0,
             "idx" : "2"
          },
    

    If you don’t get this check the IP address, the Port
    if it works then check your username and password (case sensitive)

    Hope you get it to work.



  • I have Domoticz running and I can see the lights that are “on” on the Magic Mirror screen.
    But I also have several Somfy blinds; they work fine with Domoticz, but how can I see them on the MM screen?
    Can anybody give me a help?
    Peter


  • Module Developer

    @Peter I have just updated the module. Now blinds are included.

    Just update your config.js with a ‘blindsTitle’ and add ‘blinds’ to showItems



  • @Charley can you give me some more help?
    I have 4 screens, id: 1,2,3,4 and 5 for all the screens together.
    I would like to see when the screens are open or closed.
    And if possible: with coloured symbols.
    Can you tell me what to put in config.js?
    Peter