MMM-FHEM



  • Hi All, and happy Sunday!

    has anyone of you running this module with a FHEM server running on another machine?

    i tried it with the following config but i can’t finde anything on the screen. the module is installed as i can see that it is listening to events in the debug mode.

                {
                        module: 'MMM-FHEM',
                        position: 'top_left',
                        host: '10.0.0.110',
                        config: {
                         deviceNames: [
                                'CUL_WS_1',
                                'CUL_WS_2'
                                ],
                        deviceReadings: [
                                { name: 'temperature', icon: 'wi wi-thermometer', suffix: '°' },
                                { name: 'humidity', icon: 'wi wi-humidity', suffix: '%' }
                                ],
                        },
                },
    

    FHEM is also up and running:

    0_1476617857266_Bildschirmfoto 2016-10-16 um 13.37.00.png

    Thanks a lot
    Christoph



  • @cpramhofer I didn’t know anythink about FEHM yet. But I look at your posted code and remember you write: “has anyone of you running this module with a FHEM server running on another machine?” And then I think about the line:

    host: ‘10.0.0.110’,

    Is it really the Host? It looks like a Ip. In this case is it correct?

    But, you have to know I’m didn’t use FEHM yet, and didn’t know about the config.

    By the way the FEHM serve you ran is reacheable from the Mirror IP?

    Greets gismo



  • Hello,
    yes, it work’s.

    Here is my configfile:
    config: {
    deviceNames: [
    ‘Bad’,
    ‘Wohnzimmer’,
    ‘Kueche’,
    ],
    host: [‘192.168.178.87’],
    deviceReadings: [
    { name: ‘temperature’, icon: ‘wi wi-thermometer’, suffix: ‘°’ },

                      ],
    

    Regards

    Schienw



  • @gismo2006 yes, in the readme file host is defined as an IP address. I can access FHEM from the MM Pi.

    @schienw great! i will try host as an array too…

    have a nice day!



  • Hi, OK, if the op is correct, try the other post.

    God luck! :-)

    I will happy if you post what happens. …



  • Hi all,

    i tried the setup with the following config but again, nothing is showing up on the mirror.

    {
    module: ‘MMM-FHEM’,

                        config: {
                         deviceNames: [
                                'CUL_WS_1',
                                'CUL_WS_2'
                                ],
                        host: ['10.0.0.110'],
                        deviceReadings: [
                                { name: 'temperature', icon: 'wi wi-thermometer', suffix: '°' },
                                ],
                        },
                },
    

    kind regards
    Christoph



  • Hmm… I can´t stop asking is 10.0.0.110 really the host ip of your FEHM server? Usually in privat Networks is used something like 192.178.168.2 the number one at the end op this Ip is served for your internet router… All devices then will become a other number at this end…

    greets gismo



  • Hi Gismo,

    Yes it is the correct IP
    Its a an Austrian Network from the Provider A1.
    The Router has the ip 10.0.0.138
    Magic Mirror runs in 10.0.0.101
    FHEM on 10.0.0.110 (as you also can see on the screenshot above)


  • Moderator

    @gismo2006
    192.168.x.x is a private Class C network
    10.0.0.x is a private class A network

    As you see on the screenshot cpramhofer is able to connect to the management website in a browser, so the IP address should not be the problem.



  • Oh ok, Sorry I didn´t see it in the posted screenshot till you write it. Hmm, then I couldn´t help… :-)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.