MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-WunderGround stuck at Loading




  • Project Sponsor Module Developer

    @josephsuun

    That’s an interesting way to post your request for help. You might want to describe what you’ve done so far and provide us with your config.js entry for the module, pasted into a code block.



  • Oh I sorry, I Didn’t Know that this was posted. this is my first post on this forum and my first attempt at a magicmirror. For the last week, I have been trying to get the MMM-WunderGound module to load. I tried all the other remedy,but nothing work. The Magicmirror itself load ok, but wunderground get stuck at loading.
    I’d have type “cd ~/MagicMirror/modules/”
    then type “npm run config:check” the terminal returns “Your configuration file doesn’t contain syntax error :)” I’ll include a copy of the config.js file.```

    /* Magic Mirror Config Sample
    *

    */

    var config = {
    address: “localhost”, // Address to listen on, can be:
    // - “localhost”, “127.0.0.1”, “::1” to listen on loopback interface
    // - another specific IPv4/6 to listen on a specific interface
    // - “”, “0.0.0.0”, “::” to listen on any interface
    // Default, when address config is left out, is “localhost”
    port: 8080,
    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”], // Set [] to allow all IP addresses
    // or add a specific IPv4 of 192.168.1.5 :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.1.5”],
    // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.3.0/28”],

    language: "en",
    timeFormat: 12,
    units: "imperial",
    
    modules: [
    	{
    	module: "alert",
    	},
    	{
    	module: "updatenotification",
    	position: "top_bar"
    	},
    	{
    	module: "clock",
    	position: "top_left"
    	},
                {
    	module: "calendar",
    	header: "US Holidays",
    	position: "top_left",
    	config: {
    		calendars: [
    			{
    			symbol: "mycalendar-check-o ",
    			url: "webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics"
    			},
                                {
    			symbol: "calendar-check-o ",
    			url: "https://calendar.goole.com/calendar/ical/josephsuun%40chartermi.net/public/basic.ics"
    			}
    		]
    	}
    	},
    	{
    	module: "calendar_monthly",
    	position: "top_left",
    	config: {
    				// The config property is optional
    				// Without a config, a default month view is shown
    				// Please see the 'Configuration Options' section for more information
    			}
    	},
                
    	{
    	module: "compliments",
    	position: "lower_third"
    	},
    	{
    	module: "currentweather",
    	position: "top_right",
    	config: {
    		location: "Saginaw",
    		locationID: "5007989",  //ID from http://www.openweathermap.org/help/city_list.txt
    		appid: ""
    		}
    	},
    
                 
    	{
    	module: "weatherforecast",
    	position: "top_right",
    	header: "Weather Forecast",
    	config: {
    		location: "Saginaw",
    		locationID: "5007989",  //ID from http://www.openweathermap.org/help/city_list.txt
    		appid: ""
    		}
    	},
                {
                module: "MMM-WunderGround",
                position: "top_right",
                config: {
                        apikey: "", // private; don't share!
                        pws: "pws:KTXGRAND18", //culembor
                        hourly: "1",
                        fctext: "1",
                        fcdaycount: "5",
                        fcdaystart: "0",
                        hourlyinterval: "3",
                        hourlycount: "2",
                        alerttime: 10000,
                        alerttruncatestring: "english:",
                    roundTmpDecs: 1,
                    UseCardinals: 0,
                    layout: "horizontal",
                    sysstat: 0
                        }
               },  
           {
    	module: "newsfeed",
    	position: "bottom_bar",
    	config: {
    		feeds: [
    			{
    				title: "New York Times",
    				url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    			}
    			],
    		showSourceTitle: true,
    		showPublishDate: true
    	}
    	},
               
    ]
    

    };

    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {module.exports = config;}

    I hope this help you, help me. I really want MMM-WunderGround to work.


  • Project Sponsor Module Developer

    @josephsuun said in MMM-WunderGround stuck at Loading:

    I hope this help you, help me. I really want MMM-WunderGround to work.

    I took your entry for Wunderground and tested it with my API key. It fired right up.
    0_1532049262054_123.png

    Can I ask when you got your API key? There is an issue now with Wunderground. Older API keys still seem to work but the newer ones (before they stopped issuing) don’t.


Log in to reply