MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Monitor not waking up from sleep



  • Hi All,

    So I recently had a power outage and my sd card got corrupted 😕

    Fortunately I have daily backups of my MagicMirror dirs, but not of the entire raspbian install. So I reinstalled raspbian and got magicmirror back up and running fairly quickly, but now I have this strange problem where my monitor doesnt wake up from sleep. Every day when I come home from work the monitor doesnt wake up as it used to…

    My current setup for “powersaving” my display, is MMM-NetworkScanner’s “resident” feature - so whenever the mac address of my desktop is recognized on my LAN the display turns on. This used to work great - but now I cant get the display back on.

    Not only does it not power on through the MMM-NetworkScanner resident feature (which just executes MMM-RemoteControl’s MONITORON action).

    But also the vcgencmd display_power 1 does not power on the monitor. The tvservice -p doesn’t do the trick… The “monitor on” action through the MMM-RemoteControl web interface also doesnt work.

    Any other ideas to power this thing back on?

    P.S. One of the major differences between this install and my previous one, is this time I enabled the OpenGL driver G1 GL (Full KMS) OpenGL desktop driver with full KMS via raspi-config.


  • Module Developer

    Is your Raspberry not in screensaver mode?
    It looks like the MM is not responsive.



  • No the screensaver should be off, MM seems to be responsive as I can still access the MMM-RemoteControl web interface, as well as restart MM through pm2.



  • Is the monitor really not turning on or does it just show a black screen. I have the problem that - very irregularly - I just get a black screen. I can move the mouse and see the cursor but the rest of the screen stays black. A ctrl+rrefreshes the site and and all modules are loading and showing up again. I couldn’t figure out what causes it (screensaver is disabled) but maybe it’s the same in your case? Have you tried to just refresh with ctrl+r and see what happens?



  • @madscientist

    Hi, thanks for the tip. However, the monitor is definitely off. The monitors status LED is showing off, as if no input were connected.

    I have tried restarting the mm server process through pm2, however, and that did not wake the display back up either unfortunately. I do have it set to DISPLAY :0 in the pm2 process script and it works and shows up for the first, say 6 hours of the day.

    Actually, that makes me think that it works until my desktop is turned off, which makes the MMM-NetworkScanner execute MMM-Remotecontrol monitorOff action. That is that from which it does not “wake up”, I think!

    I have tried the monitor on MMM-Remotecontrol action, and that did not work either unfortunately.

    EDIT: My desktop has been on all day - so my monitor has not had to turn off, and lo and behold its still live when I got home today. Uptime = 13 hrs. This seems to confirm my theory that it is the MMM-RemoteControl “monitor off” action that it specifically is not waking back up from…



  • Hi @ndom91
    tvservice isnt compatible with the KMS driver, you need to use fkms to retain that compativility



  • @cdelaorden hi thanks for the tip, we can ignore tvservice then. Any other way to troubleshoot what’s going on here or other toops for managing the HDMI connection?



  • @ndom91 try the fake KMS if you want to use TV service

    It’s what I do