MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Weatherforecast module problem



  • I am very new to this so please go easy. I have been searching all afternoon on the forum trying to figure out what I’m doing wrong to no avail. I have the date, weather forecast, and calendar all set to top left on my mirror. The problem is the weatherforecast is set to display 7 days but will only display 5. I tried adding the following to my custom.css but it still doesn’t work.

    }
    .weatherforecast .maxnumberofdays {
    7;
    }

    I also tried deleting my calendar out of the config.js file thinking that I was running out of room on the monitor, but still only got 5 lines of weather.
    Any help would be greatly appreciated as my head is just about mush from beating it against the wall.![alt text]0_1534032279997_mm pic.JPG



  • OK after going back and reading the readme I figured out that I needed to put the configuration in my config.js I tried this and at 7 it only shows 5 entries. If I change it to 2 it will only display 2 as it should. I think my problem is the module sizing is wrong. Where do I change the height?

    thanks for any help.


  • Module Developer

    @sgault

    There is something odd going on with that module (I think). I can’t get it to display more than 7 days, but everything below that value works as expected. Notice that maxNumberOfDays: 7, has no quotes.

    {
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "New York",
    				locationID: "5128581",
    				appid: "YOUR API KEY",
                    maxNumberOfDays: 7,
                    colored: true,
    			}
    		},


  • I took out the entry from my custom.css and put it in the config.js like it’s supposed to be. I’ve been getting the same results anything 5 or under works just fine. Don’t tell me I’ve been beating my head against the wall unnecessarily. Ugh.


  • Module Developer

    @sgault

    Don’t kill the messenger (me). I didn’t go it!


  • Module Developer

    With the free option of openweathermaps the maximum is 5 days.


  • Module Developer

    @charley

    I get 7. I’m special. 🙂