MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MagicMirror freezes in a very odd way



  • Hi all,

    I have a strange behaviour with my MM v. 2.4.1 running on a Raspberry Pi 3.
    When I start it seems to load correctly (since it shows all modules correctly), but then never updates anymore. All modules stay in their states.

    The pm2 logs give some strange message

    0|mm       | > magicmirror@2.4.1 start /home/pi/MagicMirror
    0|mm       | > sh run-start.sh
    0|mm       | npm
    0|mm       |  ERR! code ELIFECYCLE
    0|mm       | npm ERR! errno 1
    0|mm       | npm
    0|mm       |  ERR! magicmirror@2.4.1 start: `sh run-start.sh`
    0|mm       | npm ERR! Exit status 1
    0|mm       | npm
    0|mm       |  ERR!
    0|mm       | npm ERR! Failed at the magicmirror@2.4.1 start script.
    0|mm       | npm ERR!
    0|mm       |  This is probably not a problem with npm. There is likely additional logging output above.
    0|mm       | npm ERR! A complete log of this run can be found in:
    0|mm       | npm
    0|mm       | ERR!     /home/pi/.npm/_logs/2018-08-24T19_20_52_299Z-debug.log
    PM2        | App [mm] with id [0] and pid [23999], exited with code [1] via signal [SIGINT]
    PM2        | Starting execution sequence in -fork mode- for app name:mm id:0
    PM2        | App name:mm id:0 online
    

    Although I can see the display, it seems to restart again and again.
    And now it gets even more strange:
    When I stop the pm2 process (pm2 stop mm) the electron window does not close.
    And when I try to start the magic with the shell script manually (sh run-start.sh) it gives

    run-start.sh: 4: run-start.sh: electron: not found
    

    ???
    electron is obviously installed.

    Does anyone have a clue?

    npm v 6.4.0
    node v 6.14.4


  • Module Developer

    @lavolp3

    This is just a shot in the dark but my installation of MM v2.4.1 has node at v10.8.0 and npm at version 6.2.0. So, I think your npm version is fine but you might want to update your node



  • Thanks for the help @Mykle1
    Updating node didn’t solve the issue.

    But I saw that the SD card is full.
    Freed a bit of space but it didn’t help yet.
    Will also change the sd card.

    Any more ideas, anyone?

    Thanks!



  • So I have a solution for now.
    I had the fake kms driver enabled for OpenGL. Mirror worked with these for some time but at some point not anymore.
    Going back to legacy drivers solved the issue for now…