Calendar Not Loading



  • Hi, I’m having trouble getting my Calendar to load in the default calendar module.

    i have checked the link the and curl/wget downloads it just fine however when MM starts it just shows “Loading…” forever.

    I have two calendars, a google calendar and a office365 calendar. The google calendar loads fine but the office365 displays the issue above.

    Here is my obfuscated config file.

     {
                            module: 'calendar',
                            header: 'Calendar',
                            position: 'top_left',
                            config: {
                                    maximumNumberOfDays: 14,
                                    calendars: [
                                            //{
                                            //      symbol: 'home',
                                            //      url: 'https://calendar.google.com/calendar/ical/username%40gmail.com/private-4342c3561aea50c145ab3ab8320a/basic.ics'
                                            //},
                                            {
                                                    symbol: 'home',
                                                    url: 'https://outlook.office365.com/owa/calendar/cd2245088f5b4dbfa64ef416b080@company.com.au/cf65756c71a8465e97bb5470c536cce55697333579349617917$
                                            }
                                    ]
                            }
                    },
    

    When i start it with the google one uncommented it loads google fine, but no office365.
    When i start it with the google one commented out, I get:

    pi@raspberrypi:~/MagicMirror $ DISPLAY=:0  npm start
    
    > magicmirror@2.0.0 start /home/pi/MagicMirror
    > electron js/electron.js
    
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: clock.
    Initializing new module helper ...
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    All module helpers loaded.
    Starting server op port 8080 ...
    Server started ...
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: https://outlook.office365.com/owa/calendar/cd2245088f5b4dbfa64ef28e2416@company.com.au/cf65756c71a8465e97bb5470c536cce55697333579349617917/calendar.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000
    Create new news fetcher for url: http://feeds.smh.com.au/rssheadlines/top.xml - Interval: 300000
    Whoops! There was an uncaught exception...
    TypeError: curr.start.toISOString is not a function
        at Object.ical.objectHandlers.END (/home/pi/MagicMirror/modules/default/calendar/vendor/ical.js/node-ical.js:39:40)
        at Object.handleObject (/home/pi/MagicMirror/modules/default/calendar/vendor/ical.js/ical.js:257:41)
        at Object.parseICS (/home/pi/MagicMirror/modules/default/calendar/vendor/ical.js/ical.js:298:20)
        at Request._callback (/home/pi/MagicMirror/modules/default/calendar/vendor/ical.js/node-ical.js:11:24)
        at Request.self.callback (/home/pi/MagicMirror/node_modules/request/request.js:186:22)
        at emitTwo (events.js:106:13)
        at Request.emit (events.js:191:7)
        at Request. (/home/pi/MagicMirror/node_modules/request/request.js:1060:10)
        at emitOne (events.js:96:13)
        at Request.emit (events.js:188:7)
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    

    Thanks in advance.



  • Bump, anyone? Should I put an issue ticket in GitHub?



  • @clumsy_ninja I believed the link needs to end in .ics or .rss there should be a way in Office 365 to make a .ics link. I hope this help



  • @andrewchumchal Sorry, the link does, its just been cut off from how nano has displayed it.
    If i do a wget or curl I get the file just fine.



  • No, you dont need an .ics file - I’ve also included four calendars which two without a ics or rss. But its not a wrong idea.

    The followed sounds silly, sorry for that but maybe its a hint: On your posted code I miss a -> ’



  • @clumsy_ninja Is there a reason why the URL in your config file is different than the one in your log file? The one in your log file gives me a 404.



  • @tajno the URL is cut off at the “$” sign in the config file because that is how nano displayed it when i copied it. I have double checked it has a ->’



  • having the same issue with the office 365 calender.
    curl the url works, mm is not displaying it. Any ideas? @clumsy_ninja have you been able to fix it?



  • @christopherm No, I don’t think I solved it. I actually left that work so didn’t need it anymore.

    have you checked your output for errors? I was getting the same error as shown in this thread: https://forum.magicmirror.builders/topic/256/typeerror-curr-start-toisostring-is-not-a-function
    I assume it was the same issue, something todo with a bad ics file.


  • Module Developer

    I had the same problem.
    I was not using https. now it works for me.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.