MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

MMM-Remote-Control works on Remote Interface but not on Mirror



  • Hello,

    Bit a noob here. I installed the MMM-Remote-Control module following the instructions. I had a few issues with the ipWhitelist portion but was able to add both my computer and phone IP. Now I have access to the Remote Interface and I can see my Magic Mirror working on the Remote Interface but nothing is showing on the actual mirror. The screen is black. Can someone help me figure out where i went wrong?

    var config = {
    	address: "0.0.0.0", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["192.168.x.x","192.168.x.x"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    

    Please let me know if you need any more information and thank you all in advance! 🙂



  • @5m3d1n4 What is not working on the mirror itself? The Remote-control interface or the Mirror itself? DId not become clear to me.



  • @lavolp3 Sorry, the pi boots up as normal and when MM starts the monitor turns black and no modules show up. I can access the remote interface from my phone or computer. I can see the MM is working on the Remote Interface and it states some modules are active but nothings shows up on the actual monitor/Mirror. Hope that makes sense.



  • @5m3d1n4 This may be a problem with a module, not necessarily with the networking config.
    Please post results of

    pm2 logs
    

    on the mirror itself
    and also have a look at the developer’s console on the browser (usually press F12 when you have loaded MM in the browser and find the “console” tab). There you can see the messages created by Javascript loading the modules.



  • @lavolp3 thank you for helping me on this! I figured out the issue with pm2 logs

    0|mm       | Starting module: MMM-Glock
    0|mm       | Connecting socket for: MMM-MyCalendar
    0|mm       | Starting node helper for: MMM-MyCalendar
    0|mm       | Connecting socket for: MMM-Remote-Control
    0|mm       | Starting node helper for: MMM-Remote-Control
    0|mm       | Connecting socket for: MMM-MyWeather
    0|mm       | MMM-WunderGround helper started ...
    0|mm       | Connecting socket for: newsfeed
    0|mm       | Starting module: newsfeed
    0|mm       | Connecting socket for: MMM-NowPlayingOnSpotify
    0|mm       | Connecting socket for: MMM-MyCommute
    0|mm       | ====================== Starting node_helper for module [MMM-MyCommute]
    0|mm       | Sockets connected & modules started ...
    0|mm       | Launching application.
    0|mm       | Access denied to IP address: 127.0.0.1
    

    I added 127.0.0.1 to the white list and everything works like a charm now! Thank you again!!!



  • @5m3d1n4 Well that’s odd, wouldn’t have guessed this. But I’m happy for you it works.