MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Why keeps MM2 starting even when I've pressed ctrl+Q?



  • I just have installed MM2 and I would like to make changes now to the setup of MM2 but when I press Alt and close the MM2 (or use Ctrl+Q) after a few seconds MM2 is up and running agian!!
    How can I stop this? I would like to have MM2 to start after the Pi has booted or after I started it from the commanline. Not on it’s own!



  • @mwel1977 I use an ssh session from my Windows box and kill the npm start process. Actually a little script kills all node related tasks



  • @sdetweil: I’m just starting with a raspberry pi (well… I have Domoticz running on a Pi zero W to check my plants) so I have no idea how to make/write a script like that.
    But I just rebooted my pi and MM2 didn’t start. So I can make changes to the setting now and start MM2 via the commandline.


  • Module Developer

    @mwel1977 The reason seems to be pm2. You seem to have that installed. It runs a script always restarting MagicMirror after you close it.
    To close MagicMirror properly if you have pm2 running do a

    pm2 stop mm
    

    or however your process was called. You can find the name of the process running

    pm2 status
    

    Other useful commands

    pm2 restart mm
    pm2 start mm.sh //Name of the shell file that has been created by YOU!
    

Log in to reply