MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

Installing on a Pi Zero



  • @idoodler Great! I think I may have done it! I have tested most of it I think on a Pi Zero W and on a Pi 3B+; is anyone able to check whether any of my changes have affected usability on the Pi 3B and Pi 2 before I submit the pull request?


  • Module Developer

    @andyc7687 I am able to try it today, I will contact you again.


  • Module Developer

    @andyc7687 I just noticed, is this a server only installation?



  • @idoodler I didn’t really understand what was the difference between server only and not. This installs magic mirror, runs it as server only and runs three chromium browser on start-up to display it all… functionally I couldn’t tell the difference, but there might be something I’m missing



  • Pi 3B+ can run the normal magic mirror load file no need to include it in the server only script, just means you need the full fat OS on the Pi



  • @dazza120 thanks, did you test my script? I was looking at a single installer that would auto detect 2B/3B Or Zero and install the appropriate script, thereby meaning a single repo for all platforms.

    It’s able to detect 3B+ and Zero and does full install for 3B+ and server only for Zero, I don’t have a 3B though to make sure it works on that.



  • @andyc7687 no mate I done a normal install from the magic mirror bash,I’ve done it twice as I was trying to make the install as light as possible so I was trying to use Stretch with just the basic but it wouldn’t have any of it so had to install the fat version and purge all the bloat ware but from what I’ve looked at so far doesn’t use that much more ram than the lite version, only thing I ended up doing was installing PM2 manually as for some reason it wouldn’t work from the bash after restart.



  • after install on piZero (no W version) everything is ok but serveronly and browser does not start automatically. When I send from terminal:
    cd ~/MagicMirror;
    node serveronly
    server start properly, In browser manually start localhost:8080 showing MagicMirror website properly. What m i missing?



  • @12wsx straight after installation did you restart the pi zero? It should run, it’s quite a slow start up process though… if you run pm2 show MagicMirror what does it say? It takes a good minute to fire up sometimes…



  • Yes i have rebooted and wait about 10min and nothing.
    pm2 show MagicMirror says:

    root@raspberrypi:/home/pi/MagicMirror# pm2 show MagicMirror
    [PM2] Spawning PM2 daemon with pm2_home=/root/.pm2
    [PM2] PM2 Successfully daemonized
    [PM2][WARN] MagicMirror doesn't exist
    root@raspberrypi:/home/pi/MagicMirror#
    

    😕