MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Unsuccessful video streaming - help please :)



  • Hello, can anyone help, i’ve tried everything i can think of…

    I’m getting the following error when i start up Magic Mirror,

    Starting stream stream1 with args: [
    “–avdict”,
    “rtsp_transport:tcp”,
    “–win”,
    “334, 796, 686, 1038”,
    “–live”,
    “–video_queue”,
    “4”,
    “–fps”,
    “30”,
    “rtsp://admin:*******@192.168.1.77:554//h264Preview_01_main”
    ]
    Starting PM2 for omx_stream1
    PM2 started for omx_stream1
    Whoops! There was an uncaught exception…
    TypeError: Cannot read property ‘omxRestart’ of undefined
    at pm2.start (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_helper.js:156:85)
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/pm2/lib/API.js:1017:21
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/pm2/lib/API.js:1088:19
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/async/dist/async.js:473:16
    at iterateeCallback (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/async/dist/async.js:992:24)
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/async/dist/async.js:969:16
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/pm2/lib/API.js:1084:9
    at /home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/pm2-axon-rpc/lib/client.js:45:10
    at Parser. (/home/pi/MagicMirror/modules/MMM-RTSPStream/node_modules/pm2-axon/lib/sockets/req.js:67:8)
    at emitOne (events.js:116:13)
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Stopping stream stream1
    Stopping PM2 process: omx_stream1

    Any help would be gratefully received.
    Thanks
    Martin



  • @mwoodage
    Do you have the parameter “omxRestart” in your MMM-RTSPStream config ?
    I assume you are using this module.
    If yes, I would try to comment out (//) this parameter.
    Or set it to 0 (omxRestart: 0,).



  • Hi evroom, thanks for the help - I’ve searched for “omxRestart” in the config but found nothing. 😞


  • Module Developer

    @mwoodage There are some issues with the latest release of that module. Please try reverting to an older version and see if it works. I am in the process of working on a fix for it:

    cd ~/MagicMirror/modules/MMM-RTSPStream
    git checkout f583553
    


  • Thanks @shbatm - that’s cured the errors but i’m still not getting the video feed. It could be my settings so will try that first and report back.

    Thanks again
    Martin


  • Module Developer

    @mwoodage Make sure you can reach the stream in VLC or something similar first. Then try using the args that were spit out in the log to run omxplayer by itself from the command line. You may have to play with the arguments until you can get it work by itself, then you can change the module settings to match.

    omxplayer –avdict rtsp_transport:tcp –win 334 796 686 1038 –live –video_queue 4 –fps 30 “rtsp://admin:*******@192.168.1.77:554//h264Preview_01_main”
    


  • A few hours ago I was busy with this module too, as it stopped to work after I loaded the latest changes.
    I deleted and re-installed the module again; am on the origin/master branch.
    For me, the stream only started after this command:

    pm2 start omx_stream1
    

    Perhaps worth a try.

    With

    pm2 list
    

    you can see if omx_stream1 is online.

    Then I saved the pm2 config to make it boot resistant

    pm2 update
    pm2 save
    

    Btw, I do not see the

    Starting stream stream1 with args
    

    in the pm2 logs anymore.



  • Thanks shbatm - i’ve tried the stream several times on my laptop and it shows up without any problems. I’ve now installed VLC player on the Raspberry Pi and i can’t get the feed to work. I’m using exactly the same on both - any ideas?

    rtsp://admin:*******@192.168.1.77/h264Preview_01_main



  • hi evroom, thanks for the help,
    I tried what you said (after installing PM2!) but i just get the following:-

    pi@raspberrypi:~ $ pm2 start omx_stream1
    [PM2][ERROR] script not found : /home/pi/omx_stream1
    script not found : /home/pi/omx_stream1
    ┌──────┬────┬──────┬────────┬───┬─────┬────────┐
    │ Name │ id │ mode │ status │ ↺ │ cpu │ memory │
    └──────┴────┴──────┴────────┴───┴─────┴────────┘
    Use pm2 show to get more details about an app
    pi@raspberrypi:~ $

    Is that right?? I’m assuming not, as its saying script not found. I’ve un-installed omx player and re-installed it but get the same results.

    Sorry, i’m completely new to this so please be patient with me 🙂



  • Did you setup auto start according to this procedure?

    https://github.com/MichMich/MagicMirror/wiki/Auto-Starting-MagicMirror

    Perhaps it worked for me because the omx_stream was already known by pm2 in my case.
    Perhaps it needs to run once for pm2 to be useful.
    No idea.

    pm2 list
    

    Only shows mm, or MagicMirror?


Log in to reply