Error on npm install



  • So I had a working copy of MagicMirror2 running on a Raspberry Pi 2, but I was running node at version 4.2 (I think, though it could have been npm that was complaining) so I finally bit the bullet and decided to upgrade. Now I’m running node v11.6.0 and npm v6.5.0, but when I try npm install && npm start in the MagicMirror directory, I get an error after it hangs for 30-60 minutes on one piece installing. It’s not always consistent on where it fails and I’ve tried multiple times to no avail. I’ve tried removing and reinstalling nodejs. I’ve tried copying away the MagicMirror directory and running the install script and everything fails at the same point. Here’s the output:

    pi@raspberrypi:~/MagicMirror $ npm install && npm start
    npm WARN deprecated time-grunt@2.0.0: Deprecated because Grunt is practically unmaintained. Move on to something better. This package will continue to work with Grunt v1, but it will not receive any updates.
    Unhandled rejection Error: Command failed: /usr/bin/git clone --mirror -q git://github.com/patriksimek/vm2.git /home/pi/.npm/_cacache/tmp/git-clone-6428927c/.git
    warning: templates not found /tmp/pacote-git-template-tmp/git-clone-1f4f605f
    fatal: read error: Connection timed out
    
        at ChildProcess.exithandler (child_process.js:294:12)
        at ChildProcess.emit (events.js:188:13)
        at maybeClose (internal/child_process.js:978:16)
        at Process.ChildProcess._handle.onexit (internal/child_process.js:265:5)
    
    npm ERR! cb() never called!
    
    npm ERR! This is an error with npm itself. Please report this error at:
    npm ERR!     
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-01-06T06_19_57_831Z-debug.log
    
    

    I should note the error appears to be due to a connection time-out, and I’ve checked my dns and pings work fine to the outside world. Does anyone have any thoughts?



  • I’ve run npm cache clean --force also to no avail. And here’s the output of the .log file referenced in the initial error:

    pi@raspberrypi:~ $ tail /home/pi/.npm/_logs/2019-01-06T14_26_53_131Z-debug.log
    12308 http fetch GET 200 https://registry.npmjs.org/core-js/-/core-js-2.5.1.tgz 48668ms
    12309 silly extract core-js@2.5.1 extracted to /home/pi/MagicMirror/node_modules/.staging/core-js-bce1a382 (63355ms)
    12310 http fetch GET 200 https://registry.npmjs.org/clarinet/-/clarinet-0.12.3.tgz 60019ms
    12311 silly extract clarinet@^0.12.0 extracted to /home/pi/MagicMirror/node_modules/.staging/clarinet-d9485acf (60537ms)
    12312 http fetch GET 200 https://registry.npmjs.org/rxjs/-/rxjs-6.3.3.tgz 216457ms
    12313 silly extract rxjs@^6.1.0 extracted to /home/pi/MagicMirror/node_modules/.staging/rxjs-ec2c3fab (217547ms)
    12314 timing npm Completed in 9958812ms
    12315 error cb() never called!
    12316 error This is an error with npm itself. Please report this error at:
    12317 error



  • @rmeskill

    I just installed a module and it asked me to update NPM think i did it in the root directory not MagicMirror one can be sure.

    This is what worked for me
    sudo npm i -g npm



  • @paddyhughes said in Error on npm install:

    I just installed a module and it asked me to update NPM think i did it in the root directory not MagicMirror one can be sure.
    This is what worked for me
    sudo npm i -g npm

    sudo npm i -g npm didn’t work for me, got this error:

    pi@raspberrypi:~ $ sudo npm i -g npm
    /usr/local/lib/node_modules/npm/bin/npm-cli.js:85
          let notifier = require('update-notifier')({pkg})
          ^^^
    
    SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
        at exports.runInThisContext (vm.js:53:16)
        at Module._compile (module.js:414:25)
        at Object.Module._extensions..js (module.js:442:10)
        at Module.load (module.js:356:32)
        at Function.Module._load (module.js:311:12)
        at Function.Module.runMain (module.js:467:10)
        at startup (node.js:134:18)
        at node.js:961:3
    

    Trying just with npm i -g npm instead…



  • @rmeskill said in Error on npm install:

    Trying just with npm i -g npm instead…

    Did give me a positive output:

    Trying just with npm i -g npm instead…
    

    Trying npm install again…



  • @rmeskill try do it in the MagicMirror folder
    sudo npm i -g npm



  • @paddyhughes -g means global, not mm specific.



  • @paddyhughes said in Error on npm install:

    @rmeskill try do it in the MagicMirror folder
    sudo npm i -g npm

    Sudo still doesn’t work, but I tried it again just ‘npm i -g npm’ in the MagicMirror folder. Now I’m trying npm install again in the MagicMirror folder again, so I guess we’ll see, but it looks like it’s stuck at the same point as last time



  • @rmeskill looks like node is also downlevel



  • @sdetweil said in Error on npm install:

    @rmeskill looks like node is also downlevel

    Do you mean I should upgrade it? this isn’t enough:

    pi@raspberrypi:~/MagicMirror $ node -v
    v11.6.0